balenaEtcher 1.5.79 installed version and 1.5.79 portable do not start on Windows 10 1909 64-bit

The install completes but clicking on the icon opens multiple processes but no program window. The portable version behaves the same way. Using Run as administrator with the portable version is the same.

I believe 1.5.56 was the last version that worked for me on Windows 10 1903. 1.5.56 portable creates a blank program window.

Hi, welcome to the forums!

Just to confirm, if you open 1.5.79 you do not get a program window at all, correct? It’s only on 1.5.56 portable that you get the blank window.

Can you please test if 1.5.56 and 1.5.57 work on your machine? There should be no significant changes between those two.

Freshly rebooted Windows 10, 1902, 64-bit.

balenaEtcher-Portable-1.5.56.exe (md5sum bf7259481638d926c948b27b8f9e5e38):
blank window.

balenaEtcher-Portable-1.5.57.exe (md5sum 8a3dfdc6e1c5595addfc827ae1d04867):
blank window.

balenaEtcher-Portable-1.5.79.exe (md5sum 49cb69d9094159bc8fd799d7a64d55a2):
no window, task manager shows 3 Background processes labeled “balenaEtcher” and one Background process labeled “Flash OS images to SD cards and USB drives, safely and easily. (32-bit)” (I think this is the portable .exe).

When I started today, version 1.5.56 was installed on my system. I believe I had used it successfully some months ago but I could not find the icon to start it, so I downloaded 1.5.79, uninstalled 1.5.56, installed 1.5.79 and attempted to use it. When it failed, I downloaded it again, compared MD5sums, and also downloaded the portable version. Neither the installed version or the portable version worked so I started this thread. I also opened an issue (#3088) on the github site.

I downloaded and installed Win32DiskImager and successfully created an image for my Raspberry PI 3B which has booted successfully.

Thank you for making an issue, and I’m glad to hear that you got your image flashed. I checked out the issue you created, and if possible it would be good if you could share any console output, which you can see with ctrl+shift+I.

Dialog box:

DevTools was disconnected from the page.

Once page is reloaded, DevTools will automatically reconnect.

Dismissing the dialog box, clicking on the Console menu choice and there is a “>” displayed at the top of the window.

I saw you posted more information on the GitHub issue - Our team will follow up on your feedback there.
Thanks a lot,

I thought i was the only one, is there a way to download an older version that works correctly?

After 3 months without a definitive solution, I believe the answer is to use Win32DiskImager instead. I also understand that Rufus can be used as well, but I don’t need more than one solution, only one solution that works.

Hi there!

You can download older versions from here. The Etcher team just told me that there will be a new version available very soon, you might want to test it out to check if your problems went away.

I confirme the issue, there is a blank window at the starting of the software balenaEtcher-Setup-1.5.90 and also with the portable version.

So the issue is not fixed yet
Best regards,


We have a user reporting a few hours ago that a temporary workaround is to open Etcher before plugging in the SD Card. Can you check if that will work for you until the next version?

For reference, here is the link to that forum thread reporting the same problem: Etcher Opens to a Blank Screen


Indeed when my SDHC card is unplugged from my built-in card reader, the software is started as expected with blank screen. But when I plug the card after the starting, the screen becomes immediatly blank

Hi, the fix has been released now in v1.5.91. Can you please check it out and see whether it is working for you now.

I reported the problem with 1.5.79 (and noted that earlier versions also had issues). There have been 10 versions released since 1.5.79 and the problem still isn’t fixed so I believe you are overly optimistic about a fix in “a new version available very soon”.

It appears that another thread might be getting some traction, Etcher Opens to a Blank Screen

As it is mentioned in the thread that you linked, the issue has been addressed in v1.5.91, can you please check to see if it works for you?

Yes, the release 1.5.91 fixes the blank screen issue

So far, so good.