Etcher comes up with blank window

Installed latest Etcher on Windows 10. It runs but only shows a blank window.
Tried the stand-alone, but it doesn’t even show any window (doesn’t run?).

Not a good start.

Hi Bob,

Can you tell us what version of balenaEtcher you’re running? The latest is 1.5.112. Also, are you using Etcher for Windows (Installer) or Etcher for Windows (Portable)?

John

Yes, it’s 1.5.112.0

As I said, I tried both the installed version and the portable one. The installed version shows a blank window (title bar says Etcher, but the window is empty - no controls, no text, nothing). The portable version doesn’t even bring up a window at all - not even sure if it starts.

Running Windows 10 Home, x64, version 20H2, Build 19042.685, Last update KB4592438 on 12/9/2020.

Bob

Can you use CTRL - SHIFT - I to access the developer console and see if there are any error messages in the log within the console tab?

Hi,

Using Ctrl-Shift-I, the Developer Tools window opens, but with a pop-up that says:

DevTools was disconnected from this page.
Once page is reloaded, DevTools will automatically reconnect.

Nothing under Console.

– Bob

Hi Bob,
it might be connected to this bug https://github.com/balena-io/etcher/issues/3088 which unfortunately is still unsolved.
There are two things I can suggest you to try:

  1. Enable log persistence in the devtools console. This is available by clicking the cog icon, then if you refresh the window (ctrl+R focusing the devtools) you should see the previous logs. If you see any logs please copy/paste them here.
  2. Check if one of the suggested solutions here works https://github.com/balena-io/etcher/issues/2456
  3. Check if downgrading to this version works for you (another solution proposed by another user) https://github.com/balena-io/etcher/releases/tag/v1.5.56 (In your case .exe is the one you are looking for).

Got this on Refresh:

Navigated to gui.js:88093 _____ _ _ | | | | | | | | | | | ___ _ __ | || / | ’ \ / _ \ '| | || || (| | | | / | _/ ____|| ||___|| Interested in joining the Etcher team? Drop us a line at Version = 1.5.112, Type = nsis gui.js:64187 Thu Dec 17 2020 09:54:36 GMT-0500 (Eastern Standard Time) Application start ({“packageType”:“nsis”,“version”:“1.5.112”,“sample”:0.1,“applicationSessionUuid”:“8ee66a42-83a8-41a5-a87b-70d9098d6630”,“flashingWorkflowUuid”:“cda2f882-e617-4435-aec8-a061a16056b0”})

Earlier Version, same result:

Version = 1.5.56, Type = nsis
C:\Users\bob\AppData\Local\Programs\balena-etcher\resources\app.asar\node_modules\raven-js\dist\raven.js:58 Thu Dec 17 2020 10:07:49 GMT-0500 (Eastern Standard Time) Application start ({“packageType”:“nsis”,“version”:“1.5.56”,“applicationSessionUuid”:“6f764499-ba9d-4dcd-9eb9-4ba470306bf7”,“sample”:0.1})

Hey @BobPasky!
Thank you for providing the logs and for trying the earlier Etcher version. We’ve had some trouble reproducing the issue internally so we are grateful for users that are willing to troubleshoot with us.

May I ask what type of graphics card you have on your Windows 10 PC? Is it embedded, AMD, NVIDIA?

Also, I’ve seen some users have success by enabling Windows 8 Compatibility Mode on the Etcher .exe file. Would you mind trying these steps and reporting your results?

  1. Right-click on Etcher and select Properties. You can do this from the app’s shortcut or by navigating in File Browser to the EXE file.
  2. Select the Compatibility tab, then check the box next to “Run this program in compatibility mode for:”
  3. Select the version of Windows to use for Etcher in the dropdown box.
  4. Hit Apply, then run Etcher and see if this fixed your issues.

Let us know how it goes and we’ll continue to investigate the linked Github issues.

Take care,
Kyle

BTW, I’m running on an AMD Ryzen 5 1600 Six-Core Processor 3.20 GHz

The display is NVIDIA GeForce 210.

I forgot to mention it, but I tried using Compatibility Mode with Window 8 and Vista (SP2). No luck.

Thanks for your prompt responses. I’m glad you guys are trying to help. I had problems with RaspberryPi Imager, too, though it got a little further. Made it to Select SD device before it died. (I mention it in case it’s a clue to Etcher’s problem.)

(I was able to use Win32DiskImager to write to the SD card, so I know it’s possible.)

– Bob

Do other electron applications work correctly ?

I tried WhatsApp, which says it’s an electron product. It displays its opening screen with QR code, so it appears to work.

– Bob

Hello Bob,
I remember a similar issue (on Windows 7 though, not 10).
It was fixed by installing the latest Microsoft visual C++ redistribuable from https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads .
Can you try that ?