RPi3 doesn't show up in dashboard

Hi all,

Trying to get my RPi3 to show up in the dashboard, I have Internet access, I can do the API ping test fine, it says OK. I downloaded the DEV image for the RPi3. I can connect to it via SSH. I’m using WiFi on the RPI3 if that is important. Can’t seem to find anything wrong with it but still it doesn’t show up in the dashboard. Anything else I can try??

Just as an update, I’ve used the production image vs the dev image, that one works… I’ve got no clue what the difference is between the two but anyway… The RPi3 now shows up in the dashboard.

I tried both Dev and Production versions and neither one of those appear on the dashboard even though the client has working internet access.

Images tested:


// Janne

Hi @toomanyusernames, @janne_kjellman, you can find the differences between the development and production images in the documentation https://www.balena.io/docs/reference/OS/overview/2.x/#dev-vs-prod-images.

It’s weird that your devices didn’t show up on the dashboard, can you please check if the LED flashed in a pattern the same as some errors in out troubleshooting here https://www.balena.io/docs/faq/troubleshooting/troubleshooting/#error-notifications?

@janne_kjellman Did you check Trong’s suggestion on the LED flashing pattern on the RPI3? The problem might simply be that the device cannot connect to your network. Let us know if you managed to solve the problem and if you need any additional assistance.

Hi, sorry for my late reply, had some other business to attend to. For me it wasn’t a network issue, I could connect to the RPi3 via SSH, I could do DNS resolving and even the connection to the Balena API worked. It just wouldn’t show up on the dashboard. Flashed another SD Card with the production image, started and the RPi3 showed up in the dashboard immediately… No clue why.

@toomanyusernames that is very odd. Did you re-flash the same SD card or was it a different SD card all together. The only thing I can think of is that some how the original flashed SD card didn’t start up correctly due to some bad sector or it not being written properly, so it couldn’t start up the VPN, but its just a very large guess :slight_smile:

Hey, it was another SD Card I flashed, not the same. Could be a bad card, but everything else worked, it might’ve been the VPN, couldn’t really troubleshoot the VPN, couldn’t find that much info on it on the website. It is indeed a weird one. Let’s chalk it up to FUBAR or something :wink:

hmm, yeah that is a weird one. If you hit this type of thing again, you can check the vpn logs from the HostOS using journalctl -u openvpn --no-pager :slight_smile:

The thing is, I did that, it didn’t give me much information, so I’m guessing that must’ve been the problem. Maybe I will try and re-create it later, but you’ll always see that it will work that time :slight_smile:

Haha, yeah it always works when you try break things :slight_smile: