Revolution Pi is not working anymore after changing HW to CM4

We used the RevPi Core + for about 3 years now with balena and it worked great.

Now we wanted to migrate the project to RevPi Connect 4 wit the CM4 processor. We used the RevPi Connect Image and that was working so far. But now the app displays this errors:

We changed this line in the docker file:
FROM balenalib/%%BALENA_MACHINE_NAME%%-debian:latest
changed to:
FROM balenalib/aarch64-debian:latest-build
because there was an error:

This error was a bit strange, because i could access “revpi-connect-debian” manually.

What could be our problem? Thanks in advance.


I have no experience with RevPi, but I do notice that you’re saying you can access “revpi-connect-debian”, when the logs point to “revpi-connect-s-debian”

A quick search on docker hub suggests there’s only images for the non-s variant?


Where have you checked that? I checkt Github under that link:

There is the revpi-connect-s-debian file. In the post above i forgot the “s”, but i need the “s” variant, because that ist the one we installed in balena for the aarch64 architecture on the controller.


I simply checked the docker hub search for revpi-connect- and docker hub search for revpi-connect-s and the tags on revpi-connect-debian.

Maybe the image isn’t built and published with the rest?

Yes, now i see. What could be the problem, that it is not on docker hub, but on github? Who is able to change that?

This will definitely something for the balena team; note I’m just a user :slight_smile:

Judging from the github contributors, maybe @klutchell or @nghiant2710 might have an idea what’s going on?

Hey @bluesky, we’ve created the missing repositories and re-run the build jobs. I can see the images here now: Docker

Thanks for bringing this to our attention! Thank you for the assist @TJvV !

1 Like


I just wanted to reach out to say that I spoke with the Product Manager a Revolution Pi this morning and they are actually planning to send us some of their newer hardware so that we can create support for them.

I don’t have a timeline for you yet, since we haven’t sorted out shipping details, but did want to let you know that official support is coming, and I’m planning to prioritize the Connect 4 out of the hardware they send us. :slight_smile:

1 Like

@bluesky (and for others interested) the hardware from RevPi is shipping to our Integration Partner on Monday. :slight_smile: It will include the Connect 4, a few other primary boards, and some expansion modules. We’re looking forward to having their devices on the platform! I’ll try to keep this thread updated as things progress.

Hi there, any news about the RevPi?

Hello @bluesky apologizes for the delay!

This should be merged and available in balena stazging in the next few days.

We will keep you posted!

Great @mpous, thank you. Looking forward to test it.

1 Like

Hello @mpous are there any news? Is something we could test or could you help us to bring the actual software of RevPi Connect to work on the CM4 Module? It has to work soon so we can adapt our project to the new Controller.

Hello @bluesky once this PR will be merged you will be able to test it.

Thanks for your patience!

1 Like

@bluesky just wanted to share another update with you.

Since our automated tests are failing, we did still need to get the device to our Integration Partner to finish the support process. The good news is that we’ve heard from Kunbus / RevPi, who confirmed that the devices have been stuck in Germany’s customs process, but were released just recently, so they should be arriving soon. Estimated delivery is now January 11th. :crossed_fingers: We’ll keep you updated.

1 Like

Hi @the-real-kenna, thank you for the news. We were able to test the image on our controller. Unfortunately we get the same error like before, like we posted in the RevPi forum:
We hope that you find a solution to this error. Thanks


@bluesky could you please confirm if this error comes from the container? is the container privileged?

@mpous I think there are some issues with device tree overlays for the revpi-connect-4. We need to use the modbus interface but we don’t see it in the devices and it seems to be missing from the device tree overlays. If you have some suggestions or ideas for me to try, I can create balena images for the revpi-connect-4 and test them here at Munich. We have some of these devices.

1 Like

Thanks so much for the offer @wikcy_waka. You guys don’t happen to have one of our AutoKits (described in this blogpost do you? If so, we could connect it to our automated testing suite for this device…

No we don’t have it. We manually add the device into a fleet and then do some tests manually. Are you selling these anywhere or it has be made by ourselves?