ResinRequestError: Request error: App not found


#1

Hi there,
I’m a total resin noob so this might be a dumb question.
I installed the latest resin build to a Raspberry Pi 2.
Resin OS 2.13.6+rev1
Supervisor Version 7.14.0
Set to local mode.

Got github keys imported, added the git remote address copy-pasted from the dashboard, pushed code to the master. Got some unicorn ascii.

I can do ‘resin login’, and I can see my device with ‘resin apps’

Since I am using Google cloud as my terminal, as I don’t have Linux at home, I can’t do ‘resin local scan’. Instead, I try:

$ ./resin ssh
? Select a device
green-glade (83fa5b3)
Connecting to: 83fa5b3e7258f3f1d8d3d9e754795b93
ResinRequestError: Request error: App not found

Seems like I’m getting close, but there’s not much in the forum on this error.

Any idea?
Thanks


#4

Hi, have you looked at https://docs.resin.io/learn/develop/local-mode/ ? resin local ssh might be the command you need.


#5

Hi Lucian, I’m developing using gcloud. So ‘resin local scan’ just gives “Could not find any resinOS devices in the local network”.

Is it not possible to SSH into the RPi from a machine that’s not on the LAN?

From my Windows machine in the same network as the RPi, I did a local scan, which found the device, but when I tried ‘resin local ssh 83fa5b3.local’, but it says ECONNECT: socket hangup.

I’m not really sure how to create openssh credentials and use them in Windows, unless I go through the whole cygwin install process, so was hoping I could just SSH from the cloud.


#6

Turns out I needed to disable the ‘local’ setting in the dashboard. Works now :slight_smile:


#8

Did you check again as said here?

Regards,
Smith https://8ballpool.onl/

https://omegle.onl/