Installing resin CLI and sync, " $ npm install --global --production resin-cli " command , showing device offline

I am trying to complete this tutorial sucessfully. Som

After i installed resin CLI and sync i runned the" $ resin login " command, it worked, showing me this:

    [[[resin:simple-server-node shaun$ resin login
    Logging in to
    ? How would you like to login? (Use arrow keys)
   ❯ Web authorisation (recommended)
       Authentication token
      I don't have a Resin account! ]]]

i loged in using " Web authorisation" And then i run the command command
$ resin sync --source . --destination /usr/src/app
and it outputs an error shown in the attached image:

It says i dont have any device online, but my Rasberry pi3 is online (doesnt let me upload more than one image to show you the online staus but i see it on the

Any ideas? thanks!!

Here is my device showing online

@Basilisvirus this is surprising. What’s the output if you run resin devices locally?

As in our other discussion, I’d recommend trying resin local push if you have trouble with resin sync, especially on Windows. We’ve been using this very successfully for a while now, and over the coming months it’s expected to become our recommended development workflow, replacing resin sync.

I enabled local mode, i logged in again, tried “resin local push” to my ip, it asks for the docker file (probably the one in the Rpi3), cause i have all the simple-server-node files on my pc, along with the docker file.

Also the “resin devices” doesnt show any devices.

I thought using “resin bould” would help, it didnt

What does “resin local scan” say? This assumes you are in the same network with our device.

For reference, here is the documentation for resin local:

@Basilisvirus I’ve taken a look, and it appears you have two separate Resin accounts. You have an account registered with your email, which you’re using with the CLI, and a separate account registered to your github which you’ve been using in the UI.

You can see the username you’re using on the command line with resin whoami and in the dashboard in the dropdown in the top right. If your username is prefixed with gh_, that means it’s a github accont.

If you run resin login in the CLI, and choose web authentication instead of manually entering your details, then it’ll authenticate immediately via your browser, and you’re guaranteed to end up using the same account you’re logged into in the dashboard.

On the CLI commands: yes, resin build isn’t what you want - that lets you do a Docker build directly locally, and push the resulting container to

The problem with the first local deploy commands there is the missing . at the end. If should be:

resin local push -fs .

That s . is a shortened version of --source ., which is what you’re actually doing in the later command.

The 2nd problem is that right now the CLI only supports simple Dockerfiles, and the simple-server-node project uses a Dockerfile.template file. That will be added soon, but right now you’ll have to untemplate it by hand. To do that:

  • Replace %%RESIN_MACHINE_NAME%% in the template file with raspberrypi3 (assuming that’s the type of device you’re using)
  • Rename the file to simply Dockerfile (i.e. remove the .template extension)

I am planning to look at tweaking & improving the UX of some of these commands in future, I’ll definitely be taking this into account in the design there!