None of the supplied SSH keys match

First time spinning up a resin app. When running git push resin master I get the error:

None of the supplied SSH keys matched a known key for user <username>
Known ssh key fingerprints for <username>:

Please make sure you've configured your keys correctly.

The keys that get spit out in the error message match those in my github ssh settings. Tried the automated pull from github of the keys and also yanked them from my machine and pasted them in, but still no luck.

Not that I think it would be the issue here, but have a VPN and also made sure that was shut down.

Also tried to ssh into the Pi this morning with no luck. Got the following error.

$ resin ssh <my-uuid>

Connecting with: <connection-code>
ResinRequestError: Request error: App not found

I am logged into the CLI and the app is listed as “Online” in the portal.

Hi! If you are doing a git push, the keys that matter are the ones on your local machine. Also, not just having the keys, but your machine has to offer those keys up to the remote endpoint when connecting to I’m guessing this later part does not happen.

What platform are you on (Linux, Mac, Windows)?

I personally set up this entry in .ssh/config (on Linux, should be similar directory on other platforms too), to explicitly offer the specific key that you’ve added to the dashboard.

  IdentityFile .ssh/<relevant key filename>

for example (as it is common to have the id_rsa key):

  IdentityFile .ssh/id_rsa

x x x

As for the resin ssh, that one connects not into your Pi, but into the running container of your application. Since there’s no application deployed on the device, there’s nothing to ssh into yet. Once there’s a running container, you can use resin ssh or the web terminal to connect there. The host OS is not accessible with resin ssh.


Ah yes, thank you! Updating my ~/.ssh/config file did the trick.

For those who come across this, here is what my particular updated config file looked like

 IdentityFile ~/.ssh/github

  IdentityFile ~/.ssh/github

Same problem here. What to do on windows?

@ramstein74 how did you add your ssh key to your resin account?

We generally recommend you work through this guide, check you can push to GitHub and then add your keys to your resin account, at which point you should be able to push to resin.

What do you use on Windows, Git Bash? (not necessarily, looking at the shell)

Need to check where your current setup keeps your ssh keys.

it automatically imported my key from github but when i use my pc console i get that error…
user gh_ramstein74 was created automatically by resin and my github username is ramstein74

any help?

If the key is imported from your github, then the question still remains, is that key available on your local machine? What Git software you use on Windows to try to push?

this git

@ramstein74 sorry, not explained myself very clear. This git you are using, where was it installed from, is it the one on Git for Windows, or Github Desktop, or something else? The different ways of getting git will store the ssh keys differently on the machine (this is unfortunate for Windows, because on Mac and Linux it’s more uniform), and would need to know to be able to advise you. What Windows version are you using?

also tried with mingw64
notice the 3rd key. i followed this tutorial
i created a ssh key( and added it to github . than imported it to resin


can you push to github?

my app1 was not created on github yet so
I created it and pushed it
git remote add origin
git push origin master
i got a popup asking username and password , then it successfully was pushed.

Just a quick notice. I dont have a password set in my …

First check your keys are working with GitHub, to do this you need to clone the repo using SSH (rather than HTTPS which lets you use a password)

Please run git clone and see if it works.

the forum is limiting my post to 3 as i´m a new user… what else can go wrong ??? :slight_smile:

Cool, so now we need to check if you can push a new commit to the repo.

Please run:

git clone
cd app1
git commit --allow-empty -m "Test"
git push

did this ^ work?

Working now… thank you