RAK2245 Pi Hat disconnected in TTN v.3

Hi all,
I tried to follow the fantastic tutorial made by Marc and Jose to set up a basic station through balena cloud: https://www.balena.io/blog/deploy-a-basics-station-lora-gateway-with-ttn-and-balena/.
Unfortunately, my gateway (RAK2245 Hat on a rpi 4) appears as disconnected in TTN v.3.
I have reviewed the configuration several times but cannot find where is the issue.
Any ideas please?


Hello @cGf welcome to the balena forums!

Could you please share some of the logs that you get on the balenaCloud?


Hello Marc, many thanks for the quick answer.
Please find attached the lo file of Balena. BY the way, I noticed that when you click copy on the EUI from Balena and then paste it on TTN it doesnt paste the correct EUI, but truncated.
basicstation_carlos-gw-1-27.09.21_12_05_53_(+0200).txt (70.7 KB)

@cGf your gateway it’s not registered on The Things Stack as i can see on the logs

gateway_eui_not_registered (gateway EUI `DCA632FFFEA3028B` is not registered)

Did you register the gateway properly?

I think it was registered properly. I am attaching the global_conf from TTS. Maybe you can spot something wrong?
global_conf.txt (3.5 KB)

Send me a screenshot of your TTS account please! Thanks :slight_smile:

See attached. I am not sure which specific part you want to see. Shall I add you as collaborator?

Did you create an API key on TTS? Did you introduce it into the balenaCloud Device Variables as TC_KEY?

Yes, I did. I have done again. It is strange that copy paste from TTS to Balena pastes a wrong key. I have put the key manually (!!) in two variables: TC_KEY and GW_KEY, Still disconnected.

@cGf if you are running RAK2245 you must introduce as a MODEL SX1301. Could you please change that?

Could you please share the other variables? TTN_VERSION, etc?

I have changed to MODEL SX1301. Please see all the variables attached.

I understand that this is not working yet?

Correct, still disconnected.

could you please delete the gateway on TTS and try to set it up again? remember to change the TC_KEY.

Deleted the gateway and created a new one from scratch. No success.
By the way, when you copy the API key in TTS and paste it on Balena it puts this: NNSXS.K6QTAL3U4JL3P24HJP3S64WT7EF2Q7LAFVO3GNQ.HPSRUZL663BF3LU3GUIJ2GEL47CT7SHPR7W3XJIVAKCPEKQRM5YQ. This is very problematic if you dont notice it.
So, you need to cut it and leave: K6QTAL3U4JL3P24HJP3S64WT7EF2Q7LAFVO3GNQ.
Variables attached again.

Do you think you can grant me support access to your device @cGf ? feel free to DM me with your URL

Glad to hear that copying and pasting the TC_KEY solved your problems @cGf :slight_smile:

Do you have a LoRa node to test if the gateway works properly?

Hi Marc, thank you very much for your help!
I have tested the gateway with a lora node (Cube Cell HTCC-AB01 board) with a simple counter and it is working properly, see screenshot attached. So, congratulations for the great tool you have created! It makes things much easier!

1 Like

You are welcome @cGf

Let us know if we can help you with anything else :slight_smile:

Hello all,
After working properly during the last 2 days, suddenly the RAK2245 gateway appears as disconnected in TTN v3. I didn’t change anything in the configuration myself. I just noticed an error in the Balena log saying “Missing configuration, define either TTN_STACK_VERSION or TC_URI and TC_TRUST.” Maybe there is an update in the software made by Balena team or maybe an update made by TTS requiring reconfiguration of gateways? Although I have a Mirkotik gateway working perfectly with no shutdowns during the last days.
Any ideas about how to solve this?