RAK2245 pi hat connection issus

Hi all,

I am a newbie of buiilding Lorawan gateway. I tried to use RAK2245 with Raspberry pi 3 to build a gateway.

I have followed the guides below, and did a search on the forums and I saw some others who had the same problem as me. I tried their solution. For example, I’ve tried to create the API key for several times, and make sure when I copied them it’s correct. But it still didn’t work.

Below are some guides I followed:
https://www.balena.io/blog/deploy-a-basics-station-lora-gateway-with-ttn-and-balena/

https://github.com/mpous/basicstation

Here is some information from logs:

I have tried for many days and still can’t solve this problem. Any suggestions would be greatly appreciated!

Hi @ays-ibs,

If I understand the part where the flow breaks is at The Things Stack Console where the device should show up - right? You are adding the key as TC_KEY to env variables.

I looked at issues where users ran into similar key issue. Can you take a look at the following comment: RAK2245 Pi Hat disconnected in TTN v.3 - #19 by cGf ?

Basically two things to take care of:

  • For RAK2245 you must have MODEL set as SX1301.
  • The key might have the format: <prefix>.<key>.<suffix> (separated by dots); take up the key portion with a fresh TTS gateway and see if that works.

If the above doesn’t help, grant us support access and we take a look at the device config. (Ref: Grant support access - Balena Documentation)

@ays_Ibs welcome to the community!

could you please confirm that the EUI that you see on the balenaCloud tags is different than the one you see on the logs?

Having said that, did you register your EUI on the The Things Stack and added the API key on the balenaCloud?

This is related with an issue on the repo i’m working on. Could you please try this repo meanwhile? GitHub - xoseperez/basicstation: Basics™ Station Packet Forward protocol using Docker

Thank you

Hi @nitish, thank for your reply. Yes, the model is SX1301. I also double checked the API Key, and it’s the correct format as you mendtioned. But still couldn’t connect to the TTN.

I have grant you support access. Thanks a lot.

Hi @mpous, thanks for sharing this repo. I have tired the instructions in this repo.

Yes, the EUI on the balenaCloud tags is different than the one on the logs. I’ve registered EUI on the things stack and added the API Key. But unfortuantly I couldn’t connect the gateway to the TTN, and I don’t know the reason, I’ve followed evey steps…

Thank you.

1 Like

Thanks @ays_Ibs this is a reported issue we are working on → Random Wi-Fi MAC address as EUI · Issue #51 · mpous/basicstation · GitHub

having said that did you try to deploy this other basicstation repository made by a developer from the balena community?

Hello @ays_Ibs did you try the repository that i recommended?

Hi @mpous , yes, I have tried. But unfortunately I couldn’t make it work. I also deleted the whole fleet on Balena cloud and redo it again, however I still got the random EUI you mentioned above. I was wondering is there any update of solving this issues?

Thank you very much.

Did you try GitHub - xoseperez/basicstation: Basics™ Station Packet Forward protocol using Docker ?

Hi Marc, @mpous,
I encounter the same problem and also tried the repo of xoseperez. I am not sure wether or not this is helpful, but just wanted to let you know. I carefully took all the steps required but to no avail.

Kind regards,
Ronald

Hello @ronb1963 welcome to the balena community!

What device are you running? and what concentrator? Thanks