problems with raspberry pi sound

Hello, my name is Gabriel, I open this thread in the forum because I have problems with the sound of the raspberry pi, that for HDMI if it goes and for the 3.5 jack it does not go, I connect it without the hdmi and if with the jack and not with those something it happens to me that the sound does not get out where I want

Hello Gabriel, just to clarify, you want the sound to come out from the 3.5mm jack of the raspberry pi, but it was coming out of the HDMI. To try and fix this, you booted the raspberry pi without the HDMI connected, but sound still wasn’t coming out of the 3.5mm jack. Is this correct?

A few questions that will help us:

  • what raspberry pi and OS are you using?
  • what environment variables have you added?


Additionally, it would be useful if you could share the content of your devices ‘config.txt’ file

Hello, I have looked at the jack and restarted and this without HDMI still does not damage the sound through the 3.5 mm jack

Can you check if the following hdmi_force_edid_audio flag has been set in your device configuration? If so please remove it.
Please set hdmi_ignore_edid_audio to 1 so that ALSA will default to the analogue audio jack

Hello Anuj Deshpande where you can edit this configuration to get the sound out of the 3.5 mm jack

Hi Gabriel, you can set a Configuration Variable in your device through Balena Cloud. Check out the following tutorial:

Hello and to do the sound as I would, I am quite a novice in this balenasound

In order to force the sound to go through the 3.5mm jack you have to:

  • Remove the RESIN_HOST_CONFIG_hdmi_force_edid_audio, if its set
  • Set RESIN_HOST_CONFIG_hdmi_ignore_edid_audio to 1

Can you make those changes and check if the audio is sent through the 3.5mm jack?

Remove the RESIN_HOST_CONFIG_hdmi_force_edid_audio
I have not found it established in device configuration the parameter that you have told me I do not know if that is where it goes

In that case its fine. We just wanted to make sure it wasn’t set :slight_smile:

Something is wrong because it does not output the sound through the 3.5mm jack and I still think it outputs it through the HDMI and the first command is nowhere to be seen

Not finding the first item RESIN_HOST_CONFIG_hdmi_force_edid_audio is actually what we want , so that’s good. It means that variable is not assigned a value, so you don’t need to be concerned about it.

For the second item, RESIN_HOST_CONFIG_hdmi_ignore_edid_audio, on your dashboard, go to “device configuration”, scroll down and click on the “+ add custom variable” button on the right. In the popup “add a variable” window, paste RESIN_HOST_CONFIG_hdmi_ignore_edid_audio for Name. Then enter 1 for Value. Click the “Add” button. Your application will then restart with the new value. After that, please test the 3.5mm audio output and let us know if that works.

Well, I do something wrong that the audio is not removed through the 3.5 mm jack and the hdmi is disconnected from the raspberry pi

Just to confirm though, were you able to add the RESIN_HOST_CONFIG_hdmi_ignore_edid_audio variable with a value of 1?

if this value is set as you have told me

If this value is set as you have told me value 1 and nothing is wrong and I know that this output works

Can you provide some information on your setup such as the type of Raspberry Pi and the OS you are using? I can attempt to duplicate it and see if there are further settings for you to adjust. What is the source of the audio you are trying to listen to?

Hello, this is my configuration
Rpi 3b 3.5 jack connected to Denon amplifier
BalenaOS [balenaOS 2.47.0+rev1]
airplay and Bluetooth in none of the means of the balena it takes me out through the 3.5 mm jack

After setting the RESIN_HOST_CONFIG_hdmi_ignore_edid_audio variable , was the device rebooted ?