BalenaSound not working on raspberry pi 4 with 3.5mm audio jack or HDMI

Hi all, I am having trouble setting up balena sound on my rpi4 so I have come for help. I set up balenaOS with all the balenasound packages and balenacloud shows it is online, but no sound is coming out of it using airplay. I followed some of the instructions on this post, meaning I tried implementing the RESIN_HOST_CONFIG_hdmi_ignore_edid_audio to 1 variable so that it ignored the hdmi, but I still didn’t get anything through the 3.5mm audio jack. So, I tried plugging in the HDMI but still no sound, then removed the hdmi ignore variable and still nothing. Does anybody have any solutions or more troubleshooting tips?

Edit: I should add that I tried to use bluetooth as well but it would not connect to my phone.

1 Like

Hi there,
can I ask you if you followed the guide on that you can find on ? It seems like some steps have been skipped.
In addition, if you have not already tried it, I suggest you use the Deploy with balena button since everything is already configured. You can find the button at the bottom of the Getting Started guide (link above) or in the GitHub repo:

I used this guide. When I click deploy with balena it asks for an application name, what should I put?

Hey, when you use the Deploy with balenabutton, you can use balena-soundas application name, but it can be a name of your choice. As described in the guide you used, this process will just create an application on your Dashboard with the code already deployed and the right configurations. Then it will be enough to add a device and download the balenaOS disk image and then use Etcher to flash your SD with the downloaded image.

I think I used that to set up my device and I don’t think redoing it will help. I think the problem might be that the audio is not coming through the 3.5mm audio jack.

I was suggesting to use deploy with balenato just make sure that all the configurations were right. Can I ask you what version of balenaSound is running on your device ?

balenaOS 2.50.1+rev1
I was wondering because maybe I could use variables to make sure that the audio was coming through the 3.5mm jack

Hey there, what you shared is the version of the operating system. The version of the application is different. It depends on when you installed the application. However, it would seem that a very similar bug has been fixed this weekend, We had this bug in v2.4.0. To confirm it, it would be enough to see if snapcast-client logs are like those on the issue image To solve this problem you will just need to update the application, To do so redo the procedure with Deploy with balena to be able to download the new balenaSound version v2.4.1.

Oh sorry. I will try that now

Does this mean I have to reflash the image and set it all back up software-wise? Should I delete the old application?

Don’t delete the old application, you can simply check out the latest version of balena-sound using git, and run a balena push <appname> command from there. This will be delivered to your device and everything else will still work.

I don’t really understand, can you explain how to do this? I’m not familiar with git.

you should just clone the balenaSound project from this link: using the command git clone, access the folder cloned using a terminal and (if you have installed the CLI otherwise run balena push <app-name> which should in this case be app-name = balena-sound from what has been said before. This is a guide for the deploy:
once deployed the device will update automatically. If you don’t feel confident with this process, you can delete the application and redo the process with the “Deploy with balena” button.

I don’t have CLI or git installed. Can I just rewrite it and set everything back up?

Either the deploy button or the CLI/git would do it, although the former will create a new application instead of updating the one you have already. The CLI may be a bit unfamiliar if you’ve never used command-line applications before, but it’s not hard if you follow the docs. So we recommend the CLI. The button would not be as clean but it’ll get you there too.

Do you have a tutorial on how to do it with CLI?

@jsreds posted some good links above

Also, I am only using a 2 gigabyte SD card. Is that too little?

Hi @Mattpantser,

Yeah, a 2GB SD card is probably too small, but more importantly it’s probably too slow. We find that the speed and quality of SD cards can drastically affect the performance of a Raspberry Pi. We usually recommend Sandisk Extreme Pro SD cards for this reason.

Good luck!