Yet another "can't get sound from RPi 3 audio jack" question

Hello, I have just installed Balena Sound on two Raspberry Pi 3, one is a “B+” and the other a “B” and I can’t get audio from the 3.5mm jack on either of them. I have tried disabling multi room, I have added RESIN_HOST_CONFIG_hdmi_ignore_edid_audio = 1, made sure “audio=on” is in Define DT overlays. What else can I do? In alsamixer, when I press F6 to choose a sound card, I only see:
- (default)
0 vc4-hdmi
I tried
amixer cset numid=3 1

too. None of this gets audio from Spotify or Bluetooth, or from speaker-test.
What else can I do?

Here is the output from my config.txt:

root@6c7d300:~# cd /mnt/boot
root@6c7d300:/mnt/boot# cat config.txt

A bit more info, from the audio terminal:

root@fbb08b215527:/etc# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: vc4hdmi [vc4-hdmi], device 0: MAI PCM vc4-hdmi-hifi-0
Subdevices: 1/1
Subdevice #0: subdevice #0

hi, are you setting a AUDIO_OUPUT variable on the dashboard?

you can check out the documentation here:

maybe try to explicitly set it to the 3.5mm jack and see if that helps. I worry that it won’t work since your device seems to not detect the onboard audio and only indicates the hdmi port


What version and arch (32bit or 64bit) of balenaOS have you installed on your RPI3 B+ and B?

balenaOS 2.47.0+rev1

Can you help regarding the second part of the question? balenaOS comes in a 32 and 64 bit flavours for the raspberry pi 3. Check out

there isn’t a 32bit option available from the drop down on the cloud console. i installed 64bit for raspberry pi 3

Oh I see, I have to create another application to use 32bit images… I’ll try that. BRB

ok I think you might have created a raspberrypi3-64 type application, which is why the image download is only for that image type. You can try the fix mentioned here:

or start over and create a 32bit application…

upps, hehe you got it :slight_smile:

1 Like

ok, that fixed it. the 32 bit version worked “out of the box”.
Thanks everyone!