No Sound on BalenaDash Kiosk

I did a fresh pull of this project and updated the pi 4 I’ve been working with yesterday morning. For the most part it looks like everything is working correctly, and even a couple little bugs seem to be resolved… Except one major issue that wasn’t immediately apparent, there is no sound coming from the video that plays once an hour on the web page that is displayed by the pi. Is there a new variable that needs to be set in order to allow audio to play through HDMI? Any help would be greatly appreciated, and sooner the better as this is a slightly bigger issue than I thought it would be at first. Thank you!

Hi there,

There are a few reasons while this could happen.
One it could be that the broweser is not playing (how the video might be embedded)
If you add https://www.yout-ube.com/watch?v=dQw4w9WgXcQ to the LAUNCH_URL parameter, do you hear any sound?

On the balenaSound project, we saw that sometimes the RaspberryPi 4 was showing issues playing sound on the HDMI1, therefore we recomment o use the HDMI0 (that is the one next to the power connector)
and plugging the HDMI before plugging the power

Also, have you tried plugging headphones into the RPi to se if there is some sound at all coming out?

try those points and that may give us a better insight of where the problem may lay.

Let us know how it went

1 Like

@JuanFRidano Thank you for the reply! I verified that I was using HDMI0, and I even tried HDMI1, and still no luck. Oddly enough though after restarting the pi about 5 times going back and forth between the youtube video and the page I am displaying the pi started playing sound… I have no idea what made it work, but I guess it might have just been an issue with how it was booting at first, but it worked itself out. Thank you for your help, I will let you know if anything else weird happens.

Awesome! glad to hear it is working, a bit of a shame we didn’t find out exactly what it was but definitely come back to us if something weird happens! Have fun with the project!

1 Like

So a couple days ago the pi 4 stopped playing sound again. I tried rebooting it a few times, as well as setting it to play the youtube video directly and nothing. The sound just stopped playing but the website is still displayed and the video plays as it should. Also, the pi was not rebooted or unplugged in this time that I remember. I am going to go ahead and try a new distro of balena-dash and see if that solves anything, but any suggestions would be greatly appreciated!

hey @rjoel98, I’m sorry to hear that. Is there anything in the logs that may hint us to a failing service ?

fell free to post anything that may look strange to you

Hi there, this is indeed strange behaviour. If there is image coming out of the HDMI port the audio should too.
You can try adding the audio block to your docker-compose.yml and see if it helps with getting audio out of the HDMI port consistently:

  audio:
    image: balenablocks/audio:raspberrypi4-64
    privileged: true
    ports:
      - 4317:4317
    environment:
      AUDIO_OUTPUT: RPI_HDMI0

Let me know if this helps. Cheers.

Hey y’all, sorry for the late reply. But after pushing the updated files to the project and restarting the pi, it has been working since. I didn’t see anything strange in the logs before I updated the pi either, but I will continue to monitor it.

I have added the audio block to the files I have on my local device, so if there are any further issues I will push it through and keep you all updated on that also.

Thank you for all the help

Thanks for the update! Do let us know on this thread if you see any issues again