balenaSound no HDMI audio pi4

I am not able to get HDMI audio to work on my Pi4, this is even after adjusting the device configuration and rebooting. See config below. 3.5mm audio worked initially but has since been shut off with the changes made to device config. What am I missing?

Hi, can you also try adding “'hdmi_drive” and set it to value “2”?

Already tried it in my first line of configuration variables. Unfortunately it didn’t work.

This seems related to . What I would suggest is remove all those extra vars and simply boot the device with the HDMI connected, then check the output device exists with aplay -l . According to my colleague in his tests HDMI audio worked out of the box, but he will test his side again to see if something else is also needed

Just a follow up here. My colleague just tested on his pi4 with balena sound. For him it works out the box with out setting any configuration. You just need to boot up with the HDMI connected up and the OS will auto select it. He also noted that it only works on HDMI0 (the one closest to the power connector).

1 Like

Removed the extra variables and did a reboot, still no HDMI audio. How do I run the aplay -1 command? I tried to run via the terminal into the OS and got command not found.

Also, attempted some of the suggestions in the post you linked and did not have any success with that either.

Do I just need to wipe and start with a clean slate at this point? I think the HDMI port was the critical piece, but still get no audio on the correct port now, even after a reboot.

Hello Ryman,

Can you please confirm that you are using HDMI0 as Shaun indicated (the one closest to the power connector)? In case you use that port and it doesn’t work out-of-the-box, please run the command aplay -l from inside the bluetooth-audio container and reply with the output?

Thanks for bearing with us, we will see it to the end :muscle:

Thanks for the guidance guys! I appreciate you helping me and teaching me along the way. aplay -l output below.

When I first set it up, I utilized the 3.5mm jack. HDMI was not utilized till later, so I’m not sure if this is a factor or not.

**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
Subdevices: 6/7
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
Subdevice #4: subdevice #4
Subdevice #5: subdevice #5
Subdevice #6: subdevice #6
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 IEC958/HDMI [bcm2835 IEC958/HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: ALSA [bcm2835 ALSA], device 2: bcm2835 IEC958/HDMI1 [bcm2835 IEC958/HDMI1]
Subdevices: 1/1
Subdevice #0: subdevice #0

Just to be certain, have you tried turning the device off, then plugging the HDMI into the correct port (near the power connector) and finally plugging the power connector?

I have not tried that yet, only rebooting it remotely. I will try powering off, confirming HDMI is plugged in to the correct port, and then re-power on tonight when I get back.

Looking forward to the results :crossed_fingers:

Tried the above and still no success. At this point, I have nuked and started from the beginning to have a fresh, clean start. That did not work either :cry: I’m thinking it might be my adapter or cable at this point. I will try swapping a cable, after that I would need to buy a new adapter to test it.

Also tried reverting back to the 3.5mm cable for audio and after rebooting, I get nothing on that now. :sob:

Hi. Let’s first get HDMI audio working. So can you try with different cables/adapters and let us know if that changes anything?

Alright, I have tried a new adapter, different cable, different HDMI output source (ie TV rather than receiver). None of these options have worked. Still can’t get audio to transmit over HDMI and nor can I get audio on the 3.5mm anymore…I’ve really gone and buggered this up now lol

Hey @RyMan25 , it sounds really weird that its not working as expected and especially that the 3.5mm jack isn’t working anymore. I think what I would do now is make sure to validate the hardware with vanilla raspbian. That way we know the cables, pi and screen are all working as expected and that will allow us to then focus on what software/configuration is causing the issue. Can you try that?

Then from there I would create a completely new application from the balenaCloud dashboard and don’t configure anything, but boot the device up with the hdmi cable connected up. Assuming your hardware is all correct, then we should get sound out.

Alright, I will do some work with this and report results/outcome back. Thank you for all the help!

Can also confirm that RPi4 works out of the box for HDMI audio but only when plugged into HDMI0 as noted. Thanks!

Hey @lmatter,
Exactly! Our tests have shown that it only works on HDMI0 (the one closest to the power connector) and that for HDMI1 audio doesn’t work.
Please let us know if you encounter any further issues with balenaSound.