Can anyone get sound from BalenaDash on a Pi4 with a fresh download?

I’m thinking that something is broken in the current download of Balena-Dash. I can’t get a vanilla version to produce any sound - from either the headphone jack or over the HDMI port.

Is anyone successful at this? If so – could you please share your settings or what you did to make it work? I would LOVE for this to be something I can fix! I’m trying to build some video conferencing dedicated units for a tiny school. When it worked, Balena was by far the best solution.

TIA, -leo-

I did not get a chance to build this yet Leo, was hoping to get to it today, but couldnt make it to it. Tomorrow is the day, ha!

1 Like

Thanks! FYI - I know it isn’t the particular Pi4 because the same Pi gives sound fine under Ubuntu and Pi OS. I appreciate the help.

Hey. In the meantime, it would help tremendously if you could provide further relevant context:

  • Were you successfully using balenaDash before? If yes, when?
  • What means of provisioning you’re using (Hub, Deploy with Balena, other)?
  • What errors you’re getting along the way (in any)?

Yes, it worked a couple of weeks ago.
Deploy with Balena button from both Github page and Hub page.
Not seeing any errors except possibly this from the boot messages:
4.386700] snd_bcm2835: module is from the staging directory, the quality is unknown, you have been warned.


Tracking this issue here: Audio Renderer Error: Please Restart Your Computer · Issue #130 · balenalabs/balena-dash (

Outstanding - thanks so much!

RESOLVED. The Balena team looked into this and found the minor issue that was causing it. THANKS!!!

1 Like