No sound from DAC+

Hello,
I managed to set up Balena Sound according to your tutorial, thanks. I’m connecting via Bluetooth. There is sound when I use the Raspberry standard output (3.5mm audio cable), but there is no sound when I use the HifiBerry.

I’m using a Raspberry Pi3 B with HifiBerry DAC+ HW2.3.

The device configuration is set according to the tutorial
RESIN_HOST_CONFIG_dtparam “i2c_arm=on”,“spi=on”,“audio=off”
BALENA_HOST_CONFIG_dtoverlay hifiberry-dac

The log reports
image

Please help.

Is the sound clean when using rpi standard output? I’m asking because error logs look like similar to: balenaSound blueooth audio on Raspberry Pi 3: Sound skipping, dropping . Also, can you grant support access and provide device url so that we can take a closer look?

Thanks for the fast rewply. What do mean with ‘clean’? The sound is ok (as expected) when I use the RPi standard output – it’s not HiFi and sometimes there is a small gap. But this is not my issue.

My issue is that there is no sound at all when I use the HifiBerry.

Are there other parameters beside the ones in the tutorial (see above) that need to be set for a HifiBerry DAC+ HW2.3?
Are there other pararmeters or settings that provide more information about what’s wrong (e.g. in the log)?

Hi ,
the balena sound maintainer has just taken a look at this and he thinks you might be using the wrong overlay.
According to https://www.hifiberry.com/docs/software/configuring-linux-3-18-x/ he thinks you will need to use hifiberry-dacplus overlay rather than hifiberry-dac.
It could also be helpful to identify the exact hifiberry ( see https://www.hifiberry.com/products/dacplus/ ) version you are using as the required overlays might differ further.
Regards Thomas

Great, after setting BALENA_HOST_CONFIG_dtoverlay to hifiberry-dacplus it is working. My issue is solved.
The sound is moch better using the RPi standard output.
Thanks a lot for your quick help.

Glad to read that! Happy hacking!