No sound with (Supported) GPIO DAC


I recently purchased the Hifiberry Digi+ Pro and i plugged it in on the GPIO like it should

I added the configuration variable ‘BALENA_HOST_CONFIG_dtoverlay’ with value ‘hifiberry-digi’. I also added the environment variable ‘SOUND_OUTPUT’ with the value ‘DAC’.

However there is no sound output with the Airplay or the bluetooth input. the card is recognized with alsamixer (SSH on the audio block). i tried running ‘speaker-test -c1’ (SSH on the audio block) and no sound either.

I tried to remove the sound output variable, now the sound is playing through 3.5mm Jack.

I’m attempting a clean install of balena sound to see if it works then.

Going over the documentation on Hifiberry it says to use hifiberry-digi-pro as a dtoverlay value. I will test this and let you know.

Hi Abdul,

It appears like the Hifiberry Digi+ Pro isn’t on our list of supported DACs:

But that doesn’t mean it won’t work - it just means we haven’t confirmed it works, and which dtoverlay one would need. I agree that from the hifiberry docs, the hifiberry-digi-pro should work:

Please let us know what you find, and if you have any more issues.


Hello, everything seems to be working perfectly with dtoverlay from Hifiberry. I added an issue on Github incase proper support need to be coded into the software.


Winner! Thanks for letting us know. We’ll get the DAC added to the list.