Balena sound stopped working after adding BLUETOOTH_DEVICE_NAME

I had balena sound working beautifully on my RPI3. I added a wifiberry DAC and was even happier.
Decided to change the bluetooth device name. After the config apply and reboot no sound ever came out. Neither with the base RPI without dac and sound=on in dt params and remove dtoverlay and unset the device name- so back to basics - still nothing.
I’m going crazy trying to work out what happened.

Seems I get a BT connection, but nothing from the DAC output or the phono output.
Did notice a log entry:
amixer: Unable to find simple control ‘PCM’,0
but that was there from the beginning after I connected the dac (and it worked…)

Any possible help welcomed.


Hi John, thats pretty strange. Does the sound still not work even after a device reboot?

It is strange. Reboot and even swapped out another Pi. re-burned the os image. now going to push the latest code.

Let us know if you’ve had any better results with the latest code.

I actually just created a new device and it is working fine through the on-board sound. I have not managed to get the dac working, so going to run some diagnostics on it via Raspbian and see if it was a coincidental hardware fault.

I would try running the command

speaker-test -c2 -t wav

in your balena-sound service terminal window.

This command allows to check if audio (speaker) is properly configured.

1 Like

I too have the same issue, I just want to know what should be the outcome of the command speaker-test -c2 -t wav
I got something like this, is it correct

… and do you hear something ?

Normally if everything is configured fine, you should hear a voice saying in an endless loop something like :

speaker left speaker right speaker left speaker right -…

See also man page speaker-test

1 Like

Many many thanks, it worked. But I have a new problem i.e the audio pauses for 1-3 secs very frequently and sometimes the audio also overlaps. Any solution for this ?

Hi @MYBS, could you please provide more info about your setup?
Also was your setup running fine at some point? Like John in this thread earlier, have you started experiencing issues once you did some changes in the setup?

If you can enable support access and send us a link to your device, we could take a look at the logs. Perhaps the logs will give us a hint on what’s going wrong here.

Thanks for the support, the overall setup was fine since the beginning and it looks like I had messed up something and due to which it was not working. The issue with pausing for a couple of seconds still bothers me. Hopefully today or tomorrow I will provide the access.

Hi @Gelbal,
I have enabled support access and below is the link. Please let me know if need any other info.
Do I need to keep my Music player active?

I see a /usr/bin/bluealsa: Missing RTP packet: 51550 != 51548 in the logs.
This probably means that the bluetooth link is weak.
Is the bluetooth source close to the rpi3? Does it happen with other bluetooth sources?

I would also check to make sure that you only have one device connected at any one time as well. I have seen similar issues sometimes when multiple devices are connected. Keep us posted with how you get on!

Checked with another device(iPad) and it worked perfectly, no issues at all. The issue was with Android phone. Will try to fix it and will keep everyone updated.
Thanks to all for the timely support.

Fixed the pausing issue with Android phones(had issue with two android phones that I have and both got resolved) by using the below steps.
Settings–>Battery–>Battery Optimization–>All Apps–>Find your music app like Spotify etc–>select “Don’t optimize”