No Sound on RPI4 with HifiBerry DAC+ADC Pro

Dear forum members,

i am having problems getting sound out of my HifiBerry running on a RPi 4 64bit, balena OS 2.69.1+rev1. The first question is:

Is this Model (HifiBerry DAC+ADC Pro) already supported by balena-sound? It does not show up on the page of devices, but seems to be recognized after all.

I am trying a.t.m. to get sound out of the command speaker-test -c2 inside of the audio-console. The connection is attached via cinch to an amplifier and speaker, which work.

Now im happy to give you some of the output and information i found so far:

aplay -l:

Blockquote
root@60f42d0dff87:/usr/src# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: dac [snd_rpi_hifiberry_dacplusadcpro], device 0: HiFiBerry DAC+ADC Pro HiFi multicodec-0 [HiFiBerry DAC+ADC Pro HiFi multicodec-0]
Subdevices: 1/1
Subdevice #0: subdevice #0

alsamixer:

I have checked if the UDEV-Rules on my machine according to

and my soundcard was listed there already.

So those outputs / infos all seem fine to me, nevertheless, there is no sound…

Any help is highly appreciated. I hope i gave you enough information from the start, to get into fixing the problem :slight_smile:

Kind Regrads, Tobi

Hi there, just to clarify - can you hear a tone when you run speaker-test ...?

Also, if you could please review this forum post to see if it helps.

There may be a dtparam setting you are missing, you can check which one you need to set here.

One suggest is to temporarily load the HifiBerryOS to check if the hardware/connection is OK. The other thing would be to perhaps try a 32bit RPi4 OS instead of 64Bit.

Hi there,

no there was no sound running speaker-test ...
I will read through your suggested post and check the dtparam setting once again. Maybe i missed sth…

Will let you know any news, but it might take a day or two.

Kind regards and thanks for your help, Tobi

Hi there,

i was able to do some more testing:

Installing from here

Turn your old speakers or Hi-Fi into Bluetooth, Airplay and Spotify receivers with a Raspberry Pi and this step-by-step guide

with the “Deploy” Button was giving me sound on the built in RPI Headphones output out of the box with speaker-test -c2 (maybe not out of the box but once i have played sth. via bluetooth, speaker test seemed to work as well). I was using a RPI 4 model with this software version:

Using my Dashboard, creating an App and using a RPI4 64Bit device, flashing it to the SD card and subsequently using the balena CLI to push

balena-sound-master

from here

GitHub - balenalabs/balena-sound: Build a single or multi-room streamer for an existing audio device using a Raspberry Pi! Supports Bluetooth, Airplay and Spotify Connect

did not do the trick.

Eventually on the “Deploy” Version i managed to get the Hifiberry DAC+ADC PRO working as well, with changing the Device configuration to:


and turning “audio off”:

I do now hear streamed sound via the DAC and speaker-test -c2 works as well.

Is there any reason the deploy version behaves differently? I would be happy, if i could use the git-containers, because i might want to add some web interface to control audio params from there.
So an integrated, out of the box solution seems a little unflexible to me.

Kind regards, let me know if my information helps,
Tobi

Hey Tobi, thanks for your interest in the project!

The reason you see a difference between versions is the one deployed from the blog is pinned to an older release so it is missing some of the new features and fixes. The latest Github source is always the preferred version going forward, especially if you want to add your own features.

Did you try using the Hifiberry dtoverlay with the latest Github source?

Hi klutchell,

alright i understood the difference now. I have just tried to use the latest github and balena-os version, but with doing the same steps as above i do not get any sound. There are no sound cards detected (checked with alsamixer).

Just for curiosity I have tried with "sound=on", then it detects the rpi internal soundcard, but still no sound via the headphones.

I am a little lost what might be the problems, are there up-to-date instructions for

Host OS version [balenaOS 2.71.3+rev1]

to get sound running? I found a few commands for other versions and it is hard to keep track…
Kind regards and thanks a lot,
Tobi

EDIT: After unplugging the power and a restarting the RPI the hifiberry dac+adc is seen in alsamixer but there is still no sound output. Do i have to choose “DAC” actively? Although the fallback should choose that automatically!

EDIT: I found, that the red LED “D1” is not light up on the Hifiberry DAC+ADC Pro, as compared to the web-deploy version. Might this help? Might there be some voltage or interface missing? Found this: DAC+ ADC Pro LEDs – HiFiBerry

Hey Tobi, have you tried with v3.5.2? It looks like there were some recent commits that may have an impact depending how you are sending audio to the device.

Hi klutchell,

thanks for the hint. Are you referreing to this post?

I did not try that yet. Can you comment on how to update to a specific version? Can i do that from the dashboard or do i need the CLI to push the new version to my application/devices?

Little sidenote: I have installed HifiBerry OS by now and stuff works out of the box there.

Thanks for yor time and the help,

Tobi

Hey @tobik,

Thanks for getting back to us and for sticking it out throughout this process.

You can update your balenaSound setup in a few ways. You can use the Deploy with balena button (as found on GitHub - balenalabs/balena-sound: Build a single or multi-room streamer for an existing audio device using a Raspberry Pi! Supports Bluetooth, Airplay and Spotify Connect . If you’re logged into balenaCloud, it’ll either ask you to create a new app, or deploy to an existing application. Use the dropdown to select your balenaSound app and follow through with the steps. It’ll create an updated release that will then push out to all the devices on the application.

Or, you can use balenaCLI: pull the latest code from GitHub, navigate in your CLI to the folder, log into balenaCloud via CLI, then balena push .

Please let us know if this helps!