no sound coming out of raspberry pi 1b+ (2014) BalenaSound

I have a Raspberry pi that has been lying around for a while, so I decided to use it to make my speakers wireless. I then installed BalenaSound on the rpi, but have had no audio coming out of both an HDMI to VGA adapter (audio is not coming out of the adapter 3.5mm jack) or the 3.5mm jack on the pi itself. I have tried using it with many audio streaming platforms, and have connected to it over wifi as well as over bluetooth (using a USB bluetooth adapter).
Does anyone have a solution to this issue?

Hi @Plefunga welcome to the community! Could you tell us the exact version of Raspberry pi that you have, the version should be printed on top near the header pins. Could you also provide any error logs (if you have any) from the devices dashboard logs. Finally can you confirm that this raspberry pi was recently working with audio while running raspbian? I think we have seen cases where older pi’s audio stacks stopped working.

The pi’s audio was not working when using raspbian lite. The pi is version 1.2.
There were no error logs that I saw, apart from bluetooth errors, that resolved themselves.
I can see that the audio stack may be the problem, shown by the absence of audio in raspbian. Is there any way to fix that?

Hey there, is Raspbian detecting the audio device at all, or is the device there but no sound comes through?

I had a bit of a play around with audio devices in raspbian, and got audio to work. So my question now is why is it not working in Balena?

I put the sd card into my laptop and edited the config.txt file, and forced the audio to come out of the 3.5mm jack instead of the HDMI jack. Also made the display DVI mode instead of HDMI to be sure. After I did that, the audio worked.

could you please share what changes exactly did you do to the config.txt? Does it still not work with BalenaOS if you perform the same changes on its config.txt?

I uncommented the line saying hdmi_ignore_edit_audio=1 and the line hdmi_drive=1
I have done those changes twice (due to reflashing the os), and it worked both times. It does have some issues communicating to Balena dashboard, but occasionally works. It reports that it is online, and connected to VPN, but it can’t update any device variables, or restart/reboot/shutdown. Restarting and shutting down can be done through terminal, which does work.

Hello there, balenaSound maintainer here.

My guess is that you are running balenaSound in your RPi 1 in “multi-room” mode and that’s not supported, see the support matrix here. You can confirm this by checking the device logs, you should see the following line: "Multi-room master server functionality is disabled by default on device types: Raspberry Pi (v1/Zero/Zero W) and Raspberry Pi 2."

Multi-room is the default mode so unless you manually disable it following this guide, it would look as if balenaSound doesn’t work on the Pi 1. But it should work fine once you disable multi-room. Let us know if it doesn’t!