No audio out with Balena Sound on RPi3B+

Hi, this is my first posting and first project with BalenaOS. I’ve set up Balena sound on a RPi3B+ and everything went smoothly- I can see & select the device as balena sound airplay 9825 in MacOS audio apps but can’t get any audio out from the Pi jack, although I can stream OK to other airplay devices (so it’s not a source issue the headset is OK too). Is there a hidden setting? The code was downloaded yesterday so should be recent version…? Any tips appreciated! I can log in to the BalenaOS 2.47.0 on tty1as root, if that’s helpful…

Can you check the volume levels on MacOS once?
I have noticed that sometimes it resets to quite a low level after the destination has been changed to an Airplay device.

If thats not the case, can you share any logs that you might have from the dashboard?

Thanks! I’ve set quite high levels- sliders @ maximum. In the MacOS, balenaSound 9825 shows up in both Airplay and BT, so 2 instances in, say, iTunes (balena sound and balena sound airplay), neither result in any audio signal… I have 'scope on the audio jack so any signal will be visible… Audio is zero V (sorry, not sure how to get a log from the dashboard; it shows online, OS version, IP address etc)

Hi
There should be a dark-colored logs window on the right of the Device information. You should see the logs there

Hm… On the dashboard view here?

Click on the device, and you’ll be taken to the device page where you will have a lot more information about that particular device.
The screenshot that you have put is the Application view, where you will see all the devices that are part of your application (in your case you only have 1)

Ah! I didn’t know that bit. However, I downloaded the log (*.txt) but Balena won’t let me upload it in this reply for some reason (it won’t allow jpg etc but didn’t list txt)so I’ve attached another bit of screen capture…

Quick question; do you have an HDMI device connected to the Raspbery Pi perchance?

Additionally, can you please open a terminal in the bluetooth-audio container using either balena ssh or the terminal window in the device user interface and run the command aplay -l and paste the output?

Thanks,
James.

Hi, I do have the same issues here on my end. No hdmi device connected. Here my .txt logfile. Could someone help me out? thx

Sorry for delayed response (been at work), so… I got home, and tried a “reboot” of the device and it then worked fine! I then powered it off and tried again without rebooting, and it worked fine several times. ind you, the audio level is very low despite all sliders at max, so I don’t know if this is a RPi issue or code? I’d need an amp, not headphones, to listen… (Later) looked at the output circuit and I can see why the level it low with 'phones! so probably all is working as it should.

Hey there,
Can you confirm if you have set the SYSTEM_OUTPUT_VOLUME variable ? Have you already tried to watch this post? it might help

suggested post: Balena sound low output

Hey @lele79,
thanks for sharing the logs.
Could you please provide us more information on the device you are using ?

@lele79 I’m going to guess that you may be using 64-bit OS on a Pi 3? I managed to reproduce the logs you were seeing this morning. If you change to the regular Pi 3 OS, this should work fine.

Yes. thx. Fact closed here. thx