No HDMI output with FINv1.1


#1

Well,
I just received the new FIN v1.1 yesterday. Last night I uninstalled BalenaEtcher1.4.9 because I saw a newer version 1.5.5 for x64 PCs. I also downloaded “Image_2019-02-26-Raspbian-full.zip”. After a long Compute module initializing process ~ 1hr. I was able to successfully FLASH the “balena image” successfully. This morning was the test. Same results as previous FIN V1.0 board and balena’s image… No HDMI output. I haven’t hooked up serial USB adapter to see what the console is displaying.


#5

Hi there,

I believe the problem lies somewhere in the flashing process since 1 hour for the initialization is way off the standard (it should take no more than a couple of seconds). I have a couple of questions that would help us narrow down the potential options:

  • Are you using the new compute module (CM3+L) that comes with the v1.1 balenaFin?
  • Do you have the PSU connected while flashing?

I also want to double check that you’re not trying to boot the OS on the balenaFin with the USB cable connected. This is because when the balenaFin detects a USB cable on the PRG port, it is automatically put in flash mode.

Cheers,
Nico


#9

I am using cmm module included in kit. And when attempting to boot , i have hdmi and serial cables attached. I also am powering fin with included power supply. No prg usb cable is connected.
I also connected network cable.
I am connected and can communicate over serial and have performed localization for the USA. Wifi and hdmi are not present or output . I have enabled ssh and can remote in using putty


#11

The psu was not connected during flashing. Only the prg otg cable


#12

I am using a windows 10 pro x64 laptop. I have updated balenaetcher to v1.5.5. I have also downloaded and successfully flashed with new raspbian image from your site.


#13

I have also tried the echo / bash commands to enable hdmi output but get errors for each of the 3 commands . I am not infront of fin now to write actual errors about invalid syntax.


#16

Both of my fin’s the v1.0 and v1.1, both exhibited same hdmi and wifi issue. Also both appear to want to use same network address, but i am only using one at a time


#17

On both fin’s, etcher indicated a successful flash with validation.


#18

I believe I have discovered a possible issue… My two monitors that work with every other RPi and with the RPi Compute v1 and v2 are both DVI-D monitors with HDMI adapters. I have tried to force HDMI output and also added the dtoverlay=balena-fin-updated? to the /boot/config.sys file but no avail.
How can I force to DVI output?
Interestingly, my main monitor is a HP 2311gt (1920x1080 60hz on RPi’s)and the other is a Spectre X20WG-Naga LCD Monitor (with a RocketFish DVI to HDMI adapter).
I have also just reimaged my FINv1.0 and FINv1.1 with the same Raspbian image by Balena.
I also tested and setup using my Toshiba TV model 42HL167.
Both FIN’s this time connected with BT and WIFI enabled and completed PIXEL desktop initial setup and updates.
Why would the initial setup as viewed via serial console and non-recognized HDMI display yield different results?


#19

I also, painfully, tried each available resolution mode, via raspi-config/resolution and none of them upon reboot enabled HDMI output on either of my monitors (DVI and HMDI) but they did not respond. although, a vnc desktop show that a desktop was available