Can't mount Balena as an USB drive

When I connect the balena to the pc nothing happens.
Checking the device manager I have this:
see picture

And checking in the events console:

Log Name: Microsoft-Windows-Kernel-PnP/Configuration
Source: Microsoft-Windows-Kernel-PnP
Date: 6/17/2020 2:30:01 PM
Event ID: 442
Task Category: None
Level: Warning
Device USB\VID_0A5C&PID_2764\7&707db68&0&4 was not migrated due to partial or ambiguous match.

Last Device Instance Id: USB\VID_09CB&PID_1007\7&707db68&0&4
Class Guid: {36fc9e60-c465-11cf-8056-444553540000}
Location Path: PCIROOT(0)#PCI(1400)#USBROOT(0)#USB(4)#USB(2)#USB(4)
Migration Rank: 0xF000FFFFFFFF0023
Present: false
Status: 0xC0000719
Event Xml:






Hey @juliom welcome to the balena Forums!

I assume you are connecting the balenaFin to your PC to flash an image into it. Are you using etcher to do so? If you are, is the device showing up on the list? If you aren’t using etcher, which tool are you planning to use?


Etcher dont work on this pc, I’m using Raspi Imager.
please note, the pc don’t show the Balena mounted as an USB, not even in the device manager

I don’t think the Raspberry Pi Imager support flashing the Compute Module. You’ll need to download rpiboot and follow the instructions here. It’s a bit more complicated than using a flashing tool.

Regardless of which tool you prefer you use to flash the balenaFin, we’d like to understand what issues you’re facing when using etcher. Please let us know so we can help you on that end too.


etcher just don’t work anymore.
I try installing the previous version and still don’t work.
if I try to run it, nothing happens

Did etcher stop working after an update? Do you get any Windows error report when running etcher?

Hi there! I am also facing the same problem. I am using etcher but still it’s not showing balenaFin as a USB Drive. Can u help me please ?

Hi, could you please lets us know the build version of Windows, the version of Etcher and the balenaFin version?

The version of Etcher is 1.5.99 , the balenaFin is v1.0 and the Windows 10 version is quite old . I guess its 1909 build version.

Hi there, we are trying to better understand the problem. There would be much more useful information that could be obtained from the Etcher console. I would be really helpful for us if you could share these logs. These logs can be obtained by opening Etcher first, pressing ctrl + shift + i (this will open the console) and then connecting the Fin for some minutes (looking the console tab).
Otherwise, in case you can’t open Etcher, you could try to send us the logs that appear starting Etcher from the command line with the --enable-logging flag.

Hi there Sir. I did as per you have told but there aren’t any results doing that.

This is what it shows. Still the same error No Removable Drive Detected . :thinking: :pensive:

Hi @arijit,
I would first recommend to update etcher to 1.5.100 version as there were some changes that may be useful for this problem.
Then I would also recommend following the instructions here and report back to us the result to better understand if it’s an issue with etcher or rpiboot/the compute module.
Also, if you haven’t already tried it, I suggest you try changing the USB cable, just to check that the problem is not there.

Respected Sir,
I tried running by updating the Etcher and even installing all that you have told but the result came in vain.

This is what I get to see.

Hello @arijit,

I see on your screenshot that you tried rpiboot.
You should avoid running rpiboot and etcher at the same time as they will both try to access the Fin.
rpiboot should at least be showing some output when the Fin is connected.
Can you please try using another USB cable ? A short one is preferable.

Which Fin version is this ? Is the Fin powered ? Are you using the Fin DBG port ?

Its the balenaFin v1.0 and I’m using the DBG port on the Fin and I’m also powering it with the barrel connector.

Can you please try another usb cable ?
Or Etcher on another computer ?
Do you see the Fin in the device manager ? It should appear as BCM2710 or BCM2508.

Sir I have tried with 2 used cables but none of them show the Fin in the device manager. Can u please suggest of any other process ?


Are you able to successfully mount other flash or SD devices on your workstation, or is the problem only with the Fin?


Hello there Sir,

I am able to flash images onto another SD card through Etcher very easily but there’s some problem with the Fin. I guess there’s some problem with the Compute Module.