HDMI on raspberry pi is functioning during flashing?

Hi Support,
I’d like to check if it is normal for the HDMI port to be functioning during flashing. We saw that there was an image shown, but it was not properly scaled.

Is there any way to turn it off?


Hi there,

What version of the Pi are you using, and how are you flashing the SD card? Thanks!


I’m using CM3+ and flashing from laptop to the eMMC via a carrier board.


Hey there, can you give us a bit more info on the carrier board you are using, the image you are trying to flash, and what image you are seeing during flashing?

Hi, the image occurs when we’re flashing any image, it seems that when Etcher is running, the CM3+ will boot up. We think that maybe the CM3+ boots up using your boot code and then enables the HDMI.

Is there an option to disable it via a config file?

Please see attached image.


There is no option in Etcher to disable HDMI on compute modules and raspberry pi zeros while flashing.
In theory this would be possible by editing https://github.com/balena-io-modules/node-raspberrypi-usbboot/blob/master/blobs/config.txt to add
hdmi_blanking=2 as documented in https://github.com/raspberrypi/firmware/issues/352
This is not planned in the near future.

Hi and thanks for the reply.

Is it possible to adjust the resolution by adding the relevant hdmi timings to the config.txt?


Hello, yes you can do that. Have a look at the original documentatio for a full list of options

Good morning. Do not mind me asking, where would I be able to find this config.txt in my local installation of Etcher?

I tried to search on the forums, github and site, but I didn’t see any documentation specific to this.



The config.txt will be available in the image you flash, not in Etcher (Etcher is the tool to flash the image)

Hi, it seems that the display is on becuase of Etcher and not the image being flashed into Etcher. The display is operation, due to Etcher and not my image booting up.

I think there is some confusion here.

When you’re powering your CM to flash it, it starts booting and reads the config.txt from it’s eMMC. Etcher is then flashing the eMMC after the boot initialisation.

The file you need to change is on the eMMC already.


I understand what you mean, but if you look to the photo there is a “dwc2” overlay loaded, which I do not have inside my config.txt. I’ve checked again and I do not see it.

From what I’m told, the HDMI will come on after Etcher flashing process has started. I’ll check again.

So essentially, it is once Etcher detects the CM3+, then the display will come on showing the above screen and will stay on till Etcher is closed.


Hello @lwpz,

Just to clarify things a bit. As Alexis mentioned upthread, there is no way of disabling HDMI output when using Etcher.

To achieve that, you could use our implementation of the official RPi USB booting code. As was also mentioned, you will need to modify the config.txt (on node-raspberrypi-boot) and add hdmi_blanking=2.

So the process would look something like this:

  • Clone node-raspberrypi-usbboot and modify the config.txt accordingly
  • Follow the Usage instructions to run the module
  • Put your CM3 carrier into USB boot mode
  • Flash.

Keep in mind that this is not a supported feature so we can’t guarantee it will work reliably nor provide additional support for that feature.