BalenaFin V1.0 not booting up after flashing image

I received my BalenaFin V1.0 from covid19 challenge however after trying to start working on it by flashing an image of Raspbian preloaded with ROS but my board is not booting up after that and when I decided to reflash my board, it is not being detected for more than 2 sec and then showing no device detected.

Hi @version0chiro,

Congrats on getting the balenaFin! When you say your board isn’t booting, have you removed the USB connector (from flashing) and powered it on with the barrel jack power supply? Can you provide more information on what you mean by “not detected”?



Yes I have done all the troubleshooting steps, I tried inserting the usb connector before power, it shows up for a second but then the balena etcher it does not show up in the list , I have removed the the usb cable still it’s not booting up. The led state is all three being stable without blinking . Can I know if I can get a replacement in any possible manner? All my future projects are highly dependent on this board for me. I have already contacted some balena community members such as Marc Pous and have followed all steps. It would be great if it’s possible.

Hello @version0chiro

Just to clarify, when you open Etcher, you can see the balenaFin being listed for a few seconds and then it disappears from the list?

Would you be able to send us the console logs from Etcher? You can access those by pressing control+shift+i or command+option+i


yes it is correct, the moment i enter the usb and power it on, it shows up for a second before disconnecting. I have tried to include the screenshots to help you guys. Any help that can make this work would be great I am highly dependent on this

| | | | |
| |
| |
| | ___ _ __
| || / | ’ \ / _ \ '|
| |
| || (
| | | | / |
/ ____|| ||___||

Interested in joining the Etcher team?
Drop us a line at

Version = 1.5.101, Type = nsis
gui.js:132997 Wed Jul 22 2020 19:16:23 GMT+0530 (India Standard Time) Application start ({“packageType”:“nsis”,“version”:“1.5.101”,“sample”:0.1,“applicationSessionUuid”:“e0db4a93-fa39-4651-9b90-dfdf015eb754”,“flashingWorkflowUuid”:“51524eb8-36bb-40e3-970b-fd2ac1f3818d”})
gui.js:125699 Wed Jul 22 2020 19:16:25 GMT+0530 (India Standard Time) Open image selector ({“sample”:0.1,“applicationSessionUuid”:“e0db4a93-fa39-4651-9b90-dfdf015eb754”,“flashingWorkflowUuid”:“51524eb8-36bb-40e3-970b-fd2ac1f3818d”})
gui.js:125699 Wed Jul 22 2020 19:16:27 GMT+0530 (India Standard Time) Select image ({“image”:{“size”:3481272320,“name”:“2019-04-08-raspbian-stretch.img”,“hasMBR”:true,“partitions”:[{“offset”:4194304,“size”:44979712,“type”:12,“index”:1},{“offset”:50331648,“size”:3430940672,“type”:131,“index”:2}],“path”:“D:\rpi images\2019-04-08-raspbian-stretch.img”,“extension”:“img”,“logo”:false,“blockMap”:false},“sample”:0.1,“applicationSessionUuid”:“e0db4a93-fa39-4651-9b90-dfdf015eb754”,“flashingWorkflowUuid”:“51524eb8-36bb-40e3-970b-fd2ac1f3818d”})
gui.js:125699 Wed Jul 22 2020 19:17:25 GMT+0530 (India Standard Time) Show selected image tooltip ({“imagePath”:“D:\rpi images\2019-04-08-raspbian-stretch.img”,“sample”:0.1,“applicationSessionUuid”:“e0db4a93-fa39-4651-9b90-dfdf015eb754”,“flashingWorkflowUuid”:“51524eb8-36bb-40e3-970b-fd2ac1f3818d”})

Thank you. Unfortunately the log you sent does not reveal anything significant.
From your remarks further up it sounds like you are inserting external power through the barrel jack while trying to flash the Fin. The way I remember this and according to the instructions that is not neccessary. Also, please try to make sure you are using a good USB cable. Personally I have had all sorts of problems with old or just low quality USB cables.
Make sure you only connect a USB to Micro-USB cable between your system and the balenaFin’s PRG port. Leave the external power supply away. Then open Balena Etcher and check if the Fin shows up under the “Select drive” menu. If not please try to attach an etcher log again.

Sorry I gave some wrong advice in my last Post. Apparently for a fin v1.0 you need to plug the micro USB and then the power supply.

I have tried using multiple cables, ranging from my day to day data senders to my embedded based high quality but the results are same in all the cases.

Is there any way of sending it for repair or replacement if possible please tell, I know I have already said it enough but a lot depends on this board for me at current stage.

A little update, I tried plugging it in again this morning however now it’s not even being detected by computer for that short time period. It just stays dead.

Hello, thanks for your patience so far. Just as a final check, could you just confirm you have followed these steps exactly:

At the balena dashboard, create a balena application with the fin as the default device type, add a new device, and download the image (for the balena fin (CM3)).

Then try to flash the fin with that image, following these steps exactly:

  • Before powering on the Fin, connect a USB to Micro-USB cable between your system and the Fin’s USB_DBG port.
  • Now, connect power to the Fin, either using the Phoenix or Barrel connector (Do not connect power to both!).
  • Open balenaEtcher and select the OS image you downloaded
  • You should see your balenaFin listed as a Compute Module under the “Select drive” menu.
  • Once selected, two red (5V and 3V3) and one green (ACT) LEDs should be illuminated on the balenaFin LED status panel
  • The balenaFin is now ready to be flashed with an OS.

Make sure that you are running the latest version of balenaEtcher. v1.5 or above is required for flashing the CM3+L. If you are using a Linux platform, make sure you are running balenaEtcher using sudo.
After successfully flashing the OS to the balenaFin, remove the microUSB cable and power it on by either using the Phoenix or Barrel connector (Do not connect power to both!). The Fin should now boot normally into the newly flashed OS.

Yes I have followed these steps for both my windows and my linux machine but the results are nothing different, the compute module is still not detected by my machine. I have already tried troubleshooting too and yet I have no progress or change from my condition.

Did I understand correctly that your board was at first detected in etcher, you flashed it successfully with a Raspbian image, but then it did not boot afterwards. From this point on, your fin is not detected by etcher? So this behaviour only started after initially flashing the first image?

It would also be useful to see a few pictures of your setup with the cables connected, from the top and the bottom. Thanks

Hey @version0chiro

Please also send your setup photos over to so we can process the return. As soon as we receive them we’ll be able to send you a replacement.


Setup phones consist of what all targets you need? Like picture of board and compute module will do?

Yes please, the board with the compute module and also how the power and USB cables are plugged.