64gb DEVKIT ProjectFIN imaging/boot corrupt-Compute Module initializing


#1

Yesterday I received my 64 gb FIN DevKit. Following documents I connected to Windows 10 laptop to image the 64gb drive with BalenaEtcher v. 1.4.9 and the Balena RPi image (not familiar with the BalenaOS process) from the site. Before performing the image process, I saw that my laptop showed that there were boot files already present in the ROOT directory. I proceeded to shut it down and bring to my workstation and hooked up a HDMI monitor and keyboard to boot it up to see if the “imaged files” were the BalenaOS boot files. I am using the DevKit powersupply and microUSB OTG cable but no video came up, I could see some activity with the three LEDS (5v, 3.3v, and ?) The ? led was flickering for awhile and stopped. I waited an hour and tried to reboot but still no video. I again powered off and returned to my laptop, thinking that the “config?” file had no video listed nor did it have wifi . I decided to load the BalenaRPi stretch image. Just as it began the verification step it failed and indicated data stream overflow…sent xxxxx and returned xxxxx1. the screen was full of text. The option to retry was unsuccessful for both BalenaRPi images. I then Tried the standard RPi image from November and that was successful but again I had no video, even after an hour of waiting…I shutdown and again went to my laptop…This time when I connected to it using BalenaEtcher it indicates that the Compute Module is initializing… that was 10pm last night and I stopped it 7 hours later. The FIN root directory has less files now (and not those in the RPi stretch root) and leaves me confused.
What do I do?


#4

Hi there, the reason you saw boot files when you plugged your device is that the balenaFin comes with the open-source balenaOS pre-flashed. You can safely re-flash your device with your target image! THe rest of the issues you experienced seem to be related to the flashing process, can you please provide info on what Operating System your computer (running balenaEtcher) is running?


#6

I am running windows 10 64bit on my laptop. I regulary use etcher for all my RPi SD images. I have made many SD cards. The balena RPi image failed to verify with repeated attempts. I tried the RPi stretch and lite balena images same issue. I am using
supplied power supply and otg cable that came with devkit. As i indicated the standard RPi stretch image installed n verified successfully but no HDMI Video was seen. I am concerned no with balenaetcher app indicating that the FIN compute module is initializing
and does not complete to allow reflash


#8


This is the error when uploading the BalenaRPi stretch full image


#9

So last night I uninstalled BalenaEtcher 1.4.9 again, I also loaded another copy of both RaspberryPi images from this sight…Stretch and Lite. Both versions again, would not verify and the screenshot above came up. I again, flashed the official Stretch full from the Raspberry Pi download site and it installed and authenticated.
This time I was convinced that the lack of video and wifi was due to the FIN carrier board. This time I dug up my never used Raspberry Pi serial to USB connector based on the CP210X chipset. I was able to access the “imaged FIN” board. I was able to setup localization and such but NO HDMI or WIFI available. I needed my NIC connection and was able to setup SSH and VNC connections. Yes, using VNCserver I did have the Pi desktop so there is an issue with the WIFI and HDMI.
Any ideas? This FIN board is not going to work for me without working WIFI and HDMI output. I this isn’t possible then I refund may be inorder


#10

@jemartel1 can you please specify what image you are flashing on the device? also, if you get such errors while flashing it’s likely that the issue is related to the flashing and not the device itself.

Can you please try flashing the raspbian Fin edition image from here? https://www.balena.io/fin/docs/developers/#Installing-specific-Hardware-support

also, what screen output do you expect, are you flashing a distribution with a desktop environment? if so, pls pick the “2018-06-27-raspbian-stretch-fin.img.zip” image from the link above.

In order to exclude issues with etcher, can you please test this procedure for flashing the balenaFin? https://www.raspberrypi.org/documentation/hardware/computemodule/cm-emmc-flashing.md


#11

Thank you for replying. As i indicated, i did use that link as well as the lite version. Both had same issue when imaging. What should image size be after downloading from your size in the Zip format.

AS i have indicated, using etcher i can image/verify using official raspberry stretch full.

I can use etcher to image SD cards for RPis, BananaPis, windows iot without issue.


#12

thanks for the info @jemartel1 - I would like to provide remote assistance and investigate your case. Would you be able to perform the following?

  1. create an application on https://dashboard.balena-cloud.com selecting “balena Fin (CM3)” as device type
  2. click on “add device” and input your WiFi configuration. That will lead to an operating system image download
  3. Flash the downloaded image and boot the device. It will show up in your balenaCloud application dashboard
  4. click on the device appeared in your application dashboard and grant support access for 1 week from the device actions panel on the left
  5. Share with me as a private message the dashboard URL of the device that appeared

#13

How long does it take the balenaCloud dashboard to load? I have tried this link and it says “loading” for over 10 minutes…


#14

@jemartel1 something is definitely off in your network setup - can you reach https://www.balena.io/ ? if so, can you signup and access the dashboard from there?


#15

@jemartel1 something is definitely off in your network setup - can you reach https://www.balena.io/ ? if so, can you signup and access the dashboard from there?


#16

Apparently it has to do with using IE11, when I just used Chrome I can connect again… strange