Lost my account after switch to ballena-cloud dashboard


I can’t login to my account info@hallcast.com. Can you help me please ?

hey @hallcast,

Have you tried password reset?

Just to clarify here: as part of the domain change from the rename, your browser will have logged out of your account, but nothing about your account has changed, and your previous login credentials should work exactly as before.

I expect a password reset will indeed let you login again, but do let us know if there’s anything else we can do to help with that.

Password reset was the first thing i tried. But i never receive the email.

Hi @hallcast, I’ve just checked, and it doesn’t appear we have an account registered with that email address. Is there any other address you might have used?

I’m very worried. I have been logging in with that account until several days ago.

Maybe you could have closed my account for some reason?

It is the only understandable reason that I find to this problem.

@hallcast do you have the balena CLI installed locally? Assuming you have previously logged in via the CLI,balena whoami will show your username.

Otherwise, if you have a device running locally, SSH into the host and run cat /mnt/boot/config.json. The user-id attribute should point to your user account.

The command returns:
You have to log in to continue.

I see a token in ~/.resin/token
I suppose it’s expired.

That should still contain the username (or user ID) — can you please paste it here https://jwt.io and extract the value?

Here is:

  "id": 10203,
  "username": "info10",
  "email": "info@******",
  "created_at": "2016-08-20T17:55:00.982Z",
  "first_name": "Hall",
  "last_name": "Cast",
  "company": "",
  "jwt_secret": "******",
  "has_disabled_newsletter": true,
  "social_service_account": [],
  "hasPasswordSet": true,
  "needsPasswordReset": false,
  "public_key": true,
  "features": [],
  "intercomUserName": "info10",
  "intercomUserHash": "*******",
  "permissions": [],
  "authTime": 1528818183964,
  "actor": 115161,
  "iat": 1529418165,
  "exp": 1530022965

I pasted the resulting JSON.

I see an iCloud email registered for this user ID — can you try logging in with that one?

OMG !! Thank you very much !!! :see_no_evil:

No worries. Please make sure to click on “Log me out from other sessions” from Preferences > Account Details to ensure your JWT secret is rotated.