Is it possible to load ResinOS on a PC Stick (Quantum Access / Meego)?

I apologize if the question has been asked before, I did a search but have come up empty.

I have some of these and I was hoping I might be able to get some use out of them.

I created an Application and chose QEMU X86 32 Bit image. I ran dd to install the image on the PC Stick. However the machine simply does not boot.

Maybe I am just being completely dense and misunderstanding something (wouldn’t be the first time)

Hi @rpelletier you may want to give our Intel NUC image a try, it’s actually a generic x86 image and will often Just Work on other x86 devices. @floion might be able to give his professional opinion on this particular device.

I subscribe to what Alison said above. Give the Intel NUC image a try and please get back to us

Thank You @alisondavis17 and @floion. You folks are wonderful.
It appears as though this is going to work, with only one exception. The onboard wireless (RTL8723as) is not detected. I have looked at the supported list and it is not there (not really surprised). Is there a recommended way in which I might be able to add the driver? Otherwise, it is easy and cheap to just purchase a dongle. Thank you both so much. It is great news to know I can get some more use out of these things. has opened up a world of possibilities.

I spoke too soon. The image boots and loads well on the Azulle Quantum Access, but not on the MeegoPad. Is the Intel NUC image 64bit?

Just wanted to update anyone coming across this thread. The image does in fact load on the MeegoPad, however the MeegoPad uses a 32bit UEFI. Therefore, you must add the 32UEFI boot files to the boot diak and then it will install fine. Once finished, you will then need to add the UEFI files again to the stick. I might do a little write up for this as I know there are a lot of these devices floating around the Digital Signage Community. We have 8 of them, which is why I wanted to put forth the effort to see if they would work.

I have still not been able to get the wirless to work even though it appears the firmware is already built into the image. These use the RTL8723bs firmware. I did buy a couple of these at Amazon that worked without issue. So, for $11 a piece that is an easy fix, but I am a little obsessed with why the included firmware is not working for the embedded Wifi

Any ideas? @floion

@rpelletier thanks for the feedback! We’ve opened an internal issue for this.

Does the device after your modifications work well otherwise? Is the whole board 32bit, or just the UEFI part required?

Only the UEFI is 32bit. Device is 64bit. Yes, otherwise it appears to work quite well.

Thanks for the feedback! We like things that work quite well. :slight_smile:

Will keep you posted about this, looking in other forums based on the things you mentioned, there are quite a few small PCs that are in similar setup (no legacy boot nor 64bit UEFI).

Can you open an issue in about the wifi dongle support. When we have some time we’ll look into it

I actually did already, but I have a little more information now so I will try to revise it.