Resin image for qemu


Is there any support/documentation for creating a qemux86 (or qemuarm) image with Yocto and meta-resin?



Hi Alex,

I am sorry but we do not have a qemu build tested, so we do not have any specific support/doc for this machine. I am sure you should able to make it work though.
If you do not mind me asking do you have a goal beyond the qemu machines or is this a purely yocto question?

Best Regards,

Hi Theodor,

I do quite a lot of testing with Yocto qemu images as I can do that without needing board hardware setup, or having to consider any board hardware issues. I thought it might be useful for me to build up a test qemu image to look at before I move onto the real hardware. I may just go back to using an RPi in the interim instead though.

Thanks, Alex

That would be actually something we want for testing too. If by any chance you manage to get it working do ping us. We have it in our road-map but not with a high priority.

Will do. I’m currently focussed on imx6qsabresd support

hey @ajlennon, we now have both 32-bit and 64-bit qemu on resin, you can now start a new application with those from the dashboard. They are still in beta, but been tested for a little while now.

Here’s also a blogpost on using Virtualbox as well (e.g. with an Intel NUC image), in case that might help.

And there are a number of i.MX6 boards on resin, which can be inspiration for your setup (Colibri iMX6dl, and VIA VAB-820 which is an i.MX6Quad). Just as a thought.

1 Like

I tried running the above steps but my dashboard does not show any devices connected. What could be the reasons for not having this connection? I even tried changing network types but I was in vain. Does it have anything to do with the virtualbox version?

No, the virtualbox version should have nothing to do with this.
What device type is your application?