Resin OS flashes on Intel NUC, but after Flashing it still boots to windows

Dear Resin Support Staff,

I want to install the latest ResinOS (v2.12.3+rev1) on an Intel NUC (NUC7i5BNH).
At the first attempt it failed to load the resin-flash service for some reason.
As i tried it again, it ran until completion (shutdown of the device), but I had nothing in the resin dashboard.

After reading about the ‘flashing’ and ‘post-install’ states which devices in dashboard can have, I fixed the network connection and now i have a new device in the dashboard in the state ‘Post Provisioning’.

Unfortunately, if I remove the install media now and try to boot normally, it still boots into the ‘Setup your windows installation’ procedure.
I can’t figure out what happened, since the logs from flashing the device are gone after the shutdown.
Can somebody help me with this, please?

What does “windows installation procedure” mean, never encountered such thing on the NUC.

Check your bios boot configuration - you may have two options set in EUFI, also it’s worth updating the bios as it tends to be pretty old when devices ship.

The windows installation/setup procedure starts, when a fresh windows install is booted for the first time.
This is the same with every pc which has windows preinstalled.

Problem Solved:

For some reason, resinOS flasher did not format the target drive correctly or at all.
After flashing the resinOS image to the nuc, it shutdown the machine.
But when I tried to boot into resinOS, it started the normal windows setup process.

After booting a Xubuntu, i saw multiple partitions on my boot drive, 4 from Windows and 2 from resin.

Overwriting the partition table with a GPT partition table, the HDD was completely clean and installation of resinOS worked as expected.

Hi @jesuiterb - glad to hear you figured it out. By any chance, do you have logs from the times it failed? That would help us figure out if the problem was in your partition table and if this is something that we could fix / add support for. Thanks!

Unfortunately, i don’t have any logs of this time, because Resin shut down the computer after flashing and there was no time to read the output.
Maybe you should add a ‘Click Enter to proceed with shutting down the machine and removing the installation media…’ Message, to allow users to read the console output.