Help needed : Device not detecting on the BalenaCloud

Thanks for creating this amazing platform.

Device (Pi) not showing up in the BalenaCloud application when I boot the device with Cellular turned on.

I see below message the Pi connected monitor.

  • ip6_tables: © 2000-2006 Netfilter Core Team
  • “IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready”.
  • brcmfmac: power management disabled

Note: Balena cloud recognizes the device when it gets connected with the Wifi and Hologram Nova connected.

On the hologram dashboard, I see that the hologram nova is live.

Rpi3 b+
Hologram Nova

Device Type: Rpi 3
Balena OS: v2.31.5+rev1
Edition: Development
Network Type: Ethernet Only (Selected during the creation of the image.)

Added hologram-connection file under system-connections









Hey @naga and welcome to the forums!

I’m assuming you still have physical access to the device as you’re testing both with Hologram and WiFi, so have you considered connecting directly to the device whilst it’s offline, and testing the connectivity you have? As a first test, I’d make sure that you can access the balenaCloud API from the command line on the device whilst using Hologram, for example: curl should return an OK response.

Hi Chirisys,

Thanks for the quick response.

I do have the access to the physical device.

On curl, i see “couldnt resolve host message.”

I see the Hologram Nova connection light is solid blue and the Hologram dashboard says it’s live and connected.

Update: After debugging I found that

#mmcli -b 0
error: couldn’t find bearer at ‘/org/freedesktop/ModemManager1/Bearer/0’: ‘not found in any modem’.

The issue was the text encoding in the hologram-connection file.

Sharing here in the forum if anyone using Windows hologram-connection file doesn’t have any spaces.

#nmcli d
wlan0 wifi connected resin-wifi-01
supervisor0 bridge connected supervisor0
cdc-wdm0 modem connected hologram-connection

@chrisys I still couldn’t get the devices connected to the internet.

curl I see “couldnt resolve host message.”

Hey @naga I have a SIM on the way here so I can help debug this but in the meantime are you sure you still have credit? Your configuration looks fine, but I noticed the free developer/maker plan only has 1MB included which, to quote a colleague of mine, “you can blast through in basically 0 seconds” :laughing:

Hi @chrisys,

I do have the balance, that was the first step i did to make sure that i am not missing out things.

Do i need to add route to make it work? But i already see the entry on the route table for that IP GW.

Do you think did i miss some steps or any chances my device is acting in the weird way.


Hi @naga . I have actually played around with hologram on balenaOS quite a bit, so perhaps I can try reproduce this on my side. Can you tell me the following:

What OS version
What device type (I assume raspberry pi 3?)
Exact model of the Nova modem you are using.
Does your code interact with iptables or any of the network routing and have you tried this without a container running. i.e provision into a empty application.

Hi @shaunmulligan

Thanks for the response, checking on your end will be helpful.

What OS version - Balena OS: v2.31.5+rev1
What device type (I assume raspberry pi 3?) Rpi 3 B+
Exact model of the Nova modem you are using. - R410M
Does your code interact with iptables or any of the network routing and have you tried this without a container running. i.e provision into a empty application. - I tried with the simple nodejs container as well still not working. May be i can test with the empty application

Hi @naga, I think the core problem is probably the R410M. As far as I know its not fully supported in the ModemManager we have running on balenaOS, for some reason it fails due some interaction with IPV6. One of my colleagues @majorz was looking into it a couple days back with a customer, but not sure they have got any solution yet.

So unfortunately for now only the Hologram Nova 3G modem is working :frowning:

@shaunmulligan thats unfortunate.
@majorz Kindly share your finding and solution if you have one.

@majorz: Your thoughts please

Hi @naga, indeed we could not get the modem to work under the stable release of ModemManager. Quite possibly it will be supported in a next release of ModemManager. We keep our OS updated with all recent stable releases of the components involved in the networking stack and as soon as there is a new ModemManager version we can check it again. I saw on some of the Hologram pages that they do not support ModemManager, so I assume it may not be a priority on their side:

@majorz Thanks for your response. I see that the Pi gets connected to the Cellular connection using nova occasionally. The links answers the question of unstable connection.