no device detection on Balena Cloud

Hi there,

I tried to setup Balena Fin and followed the link:

i have successfully tested out Balena CLI, and it is like this:

after that , I tried to reload the Balena Cloud page, but there is no device detected, i tried multiple times, could you help me solve out what problem it might be.


Hello George,

If you had no issues provisioning the device with Etcher, and it all went like in the link you send us, it could be a connectivity problem, try using an Ethernet cable.

If on the other hand you are not sure is the provisioning was successful, check that:

  • the compute module is properly inserted.
  • If you are on windows you need the usbboot drivers to expose the eMMC installed
  • try another USB cable
  • errors during flashing in balenaEtcher can also be seen in the console (pressing Ctrl + Shift + I)

If that is also not the case, can you let us know which Fin version you have and what do the LEDs do when/after flashing?

I hope any of these tips help