GNOME application icon missing

I am uncertain if this is an issue in my configuration, or a bug in balena etcher itself. I at first thought it was an issue in my config, but I opened nautilus as root and searched for “balena” and deleted all related files on my main partition that were related to the app after examining the path for each one, restarted the shell, and tried running the app image again after a redownload. Still no icon in the drawer. I don’t know if I screwed up or something is wrong with the app itself. Any advice would be appreciated. I’m running Ubuntu 19.10 with the default GNOME shell. If there’s any other info that’s needed, let me know. Thanks for your help!

IMHO it is a goofy thing. when you launch the application from the .app file. The “Green Cube” icon will appear on your “favorites” bar. Right Click on it & "add to favorites. Else I have the “.app” file on my desktop anyway. Just like Ultimaker.

Hey @MikeRL, thanks for the report. And thanks for chiming in @joelhuebner. My teammate who maintains Etcher responded with this in another post:

We had to upgrade the electron-builder module to version 21 which doesn’t include that functionality anymore, so while it’s not done 100% intentionally (as in, not for that reason), we had to upgrade for a number of other reasons (e.g. support for newer macOS Catalina)

We are tracking this issue in our github page: https://github.com/balena-io/etcher/issues/2371 We’ll follow-up when we make progress.

So you could perhaps follow Joel’s suggestion for now.?

1 Like