balenaetcher not working on zorin os

i downloaded balenaetcher for linux and tried to run it, but it only shows a blank window, does anyone know why?

1 Like


Thanks for reaching out. Can you share a bit more about your installation method?

  • What distro are you running?
  • Which installation method did you use?
  • Are you able to see the console at all, in order to grab logs using ctrl + shift + i?

Any other details you think might help us troubleshoot the issue are appreciated!

hi, i’m running zorin os and i tried to install balena ethcer by downloading the .appimage file from the website. i’ve checked the console and there are two error messages, here’s a screenshot of the console

I also am experiencing this since the last Zorin update.

Hi both, can you just let us know if you downloaded Etcher from this webpage: balenaEtcher - Flash OS images to SD cards & USB drives

We are aware that there are several other sites which promote Etcher as a tool but might have outdated versions on their site so I just wanted to check you have used our official download and have the latest version before escalating this ticket to the Etcher team?

Yes, that is where I downloaded it from.

It appears that Zorin removed GLIBC in their latest update. We will be working on updating our builds to account for that, but in the mean time you can follow this post by a community member to build your own version of Etcher on Zorin: files/ at main · Pi-Apps-Coders/files · GitHub

I’ve just tested it, the process works great.