BalenaEtcher repository not found

This morning, when launching my Ubuntu laptop update, the process failed.
I have to disable BalenaEtcher repository in Muon’s configuration list in order to unblock the platform update.
It seems is no longer available
(my update source line is “ stable etcher”)
Could you please tell me if this conf is still right, or if I have to modify it ? (and how ?)
Thanks by advance.

Hi there, last week we did make a change to our PPA provider, and are now hosted at CloudSmith. You’ll need to add the new repository by following the instructions here: GitHub - balena-io/etcher: Flash OS images to SD cards & USB drives, safely and easily.

It basically just needs this run:

curl -1sLf \
   '' \
   | sudo -E bash


Thanks very much.
Repository has been changed. Now it’s OK.

Good to hear that worked for you, feel free to contact us in case you have more questions.

By the way ( :yum: ), this morning when updating my laptop through Muon deb packager, I receive this error about repositories :

Perhaps I misunderstood, but I believe BalenaEtcher was free.
Please keep me informed.


Thanks for reaching out and reporting this issue. BalenaEtcher is infact free. The Etcher team is looking into the issue and we will keep this thread updated with further developments.

just FYI, today error does no longer appear.
Have you modified something ?
Perhaps it was a cloudsmith side issue that they solved meanwhile.
In any way, if it occurs again I’ll wait 2 or 3 days before notifying you.


Indeed - our developers were working on it recently, after a similar issue was raised on the forum.
We have implemented something that fixes this for the time being. We are working on a long term solution as well, so do let us know if you see similar issues again. Thanks for your help!