balenaEtcher 1.58.89 App image can't be invoked

I downloaded the latest balenaEtcher app image, and deleted the old one. I double the new one to get started but nothing happens at all. I restarted the computer redownloaded the image but its not working. the app image was located in my home dir. but are there any locations where any “dependency” file so I can completely erase everything and start from scratch.

Hello, Could you tell me:

Debian 10 x64

Hello, on Debian you can use the deb packages:
If you have time, can you please share the terminal output of running the AppImage: ./balenaEtcher-1.5.89-x64.AppImage ?

I downloaded the x64 but it didn’t do anything. then tried x86 to see if that would work but no bueno.

You mean the deb package ?
If you’re on a 64bit version of debian, you should use the 64bit package.
What happens if you run balena-etcher-electron in a terminal ?

Will do

I need to use wget to download the packages? I’m very good at using wget

Any http client should work :slight_smile:
Your browser, wget, curl, anything should work

When I run balena-etcher-electron. It says command not found

here is a screen shot of using wget and tying to invoke etcher

You need to install the deb package after downloading it:
sudo dpkg -i balena-etcher-electron_1.5.89_amd64.deb
Then run it

do i use dpkg to install the dependencies?


You should be able to run apt-get install -f```` after running the dpkg``` command to install dependencies.


thank you all for the support

I have a question. Do you always have download .deb packages when after using wget to download something?

P.S. the image appeared thank you
for you support i’m going to test it out

Hi @Eboogie, nice to hear you made progress. Let us know if you encounter any issues.

Do you always have download .deb packages when after using wget to download something?

Not sure if I understand the question. Your Linux OS Debian uses deb file format for distributing application packages. Ubuntu also used deb format. MacOS and Windows uses other file formats.

So I used wget to download balenaEtcher. But it still didnt work. Then I used dpkg -i to get the.deb packages. But should had the .deb packages get installed with wget.

Hi @Eboogie, wget just downloads the balenaEtcher binary but it doesn’t handle installation of dependencies like apt-get does. You will still need to install the .deb packages using dpkg -i before you are able to use Etcher.

The easiest way to set up Etcher is to follow the installation instructions for Debian on this link:

I hope this helps you well.


Thank you for the clarification