Getting Balena Sound to work on Raspberry Pi 3

I have been struggling to get balena sound to work on my Raspberry Pi 3. I’ve finally got it to work and found the following were needed:

  • you must use the 32-bit Raspberry Pi device (Raspberry Pi 3) not the 64-bit one
  • obviously you must also use the 32-bit OS
  • don’t use HDMI to monitor the Pi booting, as it will send the audio out over HDMI rather than the jack output.
  • Alternatively, set the device configuration variable RESIN_HOST_CONFIG_hdmi_ignore_edid_audio to 1, as was pointed out in another post

Hope this helps!

1 Like

Thanks for putting these suggestions in one place. I’m running two RPI 3B v1.2’s and configured exactly how you suggest without success. I can get audio out of the 3.5mm plug by disabling multi-room audio, but that’s the whole point of Balenasound for me. I’m trying Airplay and Bluetooth, both of which were successful with multi-room audio turned off.

I have two RPI 4’s en route and plan to use one as the server but would like to get these RPI 3B’s up and running in the meantime as an initial use case, even if the audio has issues because the 3B’s don’t work well as the snapcast server. Hoping someone will see this message and give some suggestions. Thinking maybe I need to focus on snapcast configuration settings since the audio works when fleet supervisor and snapcast are disabled (disable multi room)…

My phone and computer can connect to the rpi and it makes a sound when its connected. But when i start streaming music from spotify there is no sound. Can anyone explain, what could be the problem. I think its the output which is set to HDMI, but i cant figure out, how to change it to jack

Discovered a latency flag was required for snapcast client to function. BalenaSound, Multiroom Audio Not Working, Missing Device Latency Value (Solved)