Flashing Raspian Buster to SD card fails at 65-ish percent

Etcher version: 1.5.39
OS: Win 10 64 bit
Logging output: https://pastebin.com/1jp4vPGF

I’ve never encountered this before while using Etcher. I’m guessing my SD card is just broken somehow, even though I can still use it on my PC. I’ve tried flashing multiple times, also tried win32diskimager, which also failed.
Can you guys tell me what’s going on exactly?

Hey @timmiej93 ,

Are you plugging the SD Card using a built-in adapter or a USB dongle? Can you try connecting it in a different way and see if the issue persist? Also, do you get the EIO error on the same percentage all the time?

This might indicate that there is a particular sector in the SD Card that is faulty, or that there is a problem with the reader. Using it on your PC might still work as you might not be hitting that particular sector.

Hi @jviotti, thanks for the reply.

I’m using a USB dongle, and it indeed seems like that was the issue. Using my laptop works just fine. I guess I’m gonna need a new adapter.
Thanks for your help

Just as I said that, it completes validating and says “1 Failed device”. Maybe the SD card is busted as well…

Yeah, it sounds like it. A good indicative is to see if given the same image, the SD Card always fails at the same percentage, and if so, the best thing to do is to just replace the card.

1 Like