Flashing Raspberry Image to SD card always Fails

I have tried to flash several copies of the Raspberry PI raspbian image and it always comes back as failed.

The image is: 2018-04-18-raspbian-stretch.img
The card SD card is mounted on an ANKER USB - SD card adapter.
The SD card is a Kingston 32 GB card, but I have tried several.
I am on Windows 10 build 1709

Hey there!

What image flasher are you using? Maybe try Etcher (https://etcher.io) and use its validating mechanism to rule out any SD Card / adapter problems?

I am using Etcher. That is what is giving me the error that it has failed when it does the verification. I have used other utilities and get no errors and no problems with the images, but those utilities are not doing a verification pass.

That sounds like the problem. Other tools don’t do verification, so they are not catching this. Can you try other SD Card adapters, or other adapter port?

I have now tried other ports, a regular USB thumb drive, even a different computer. ALL transfers I do with Etcher of this image ALL come back failed on verification.
Could there be something wrong with the image or with Etcher?

Where did you get the image? It doesn’t look like a resinOS image, from the name.

From here:


Download ZIP

I see. I’d suggest flashing it using a different tool and confirming whether it’s etcher or the image that has the problem. What OS are you using to flash with?

I am on Windows 10 build 1709

I was having the same problem - nearly every attempt to write Raspbian to an SD card failed. Turns out it was caused by having my SD card reader attached to a weak USB hub, in this case the one built into my monitor. When I plugged it directly into my motherboard, writes stabilized. Hope that fixes it for you.

1 Like

Thanks for the feedback!