Flash from NAS?

Hi!

I’ve been investigating the possibility to flash from my synology DS NAS. Hence I tried the “use image URL” option. On the LAN this seems to work at least if you try using python3 i.e python3 -m http.server. However if I try to serve URL to my NAS source I get this warning message “Error: unable to verify the first certificate”. Important to mention is that my nas is reached through https and is password protected. My questions is, does etcher work with source that is behind a password protected https requests? My nas doesn’t have any official certificate.Thanks!

Hi Chris,
just to clarify: You are using etcher on some device to flash images that are on your NAS ?
How about mounting the image via SMB share ?

Hi samothx!

Thanks for replying! Yes that was the attempt at least. I had an SD card connected to my laptop (win10) that it self was connected to my NAS via the LAN. The python server part was setup on another win10 PC though.
Honestly at this point am both learning and trying to evaluate the best and efficient way to handle .img files from Raspberry Pi. In conjunction to testing etcher i tried PiShrink.sh script and imgclone script (both from github) to shrink and use the .img with etcher. This why I tried using the flashing from URL part to not be forced to only use etcher from local drives. Maybe etcher doesn’t have the ability to promt for password or ignore self renewable certificates?

Imgclone was tested with mounting the drive from the RPi using DS as destination drive during backup but with etcher it would be as source drive for restore. I guess it would be nice to know if etcher has some limitation in how it can access network shares. Becuase it seems to be able to access the LAN share if it’s http and not password protected like in the case with the python server.

I would also like to take the opportunity to ask in case you have some knowledge. These scripts seems very good in particular PiShrink to shrink the .img file by reducing empty space however I concluded that PiShrink never produce .img file with the same sha256 hash, do you know why?

etcher doesn’t have the ability to promt for password or ignore self renewable certificates

Correct, that is not something we support but if you already have something in mind and want to give it a try, you could make a pull-request at https://github.com/balena-io-modules/etcher-sdk - the class responsible for online sources is https://github.com/balena-io-modules/etcher-sdk/blob/master/lib/source-destination/http.ts

As for PiShrink, I don’t see any clear explanation to why it would not produce a file with the same sha256 hash, have you already tried opening an issue to ask on their github repository?

Thanks for you answer thundron!

At least I know what etcher can and can’t do clearly. Sounds tempting but I think it’s out of my scope of coding knowledge.

I tried opening a thread at raspberrypi forums but I really have 0 replies which is very strange to me.

I might try the github repository. Anyways thanks!