Flash filed again and again and again

I’ve seen so many YouTube videos singing the praises of Balena Etcher to install an OS on the Raspberry Pi. So far my experience has always – always – ended up with “Flash Failed”. So frustrating!

And the research I’ve gathered to resolve the issue ranges from a bad SD card to not using SanDisk. Well, I’ve gone through at least 3 SanDisks and feel pretty confident it can’t be a bad card on all of those.

And I just now tried installed Manjaro (manjaro-xfce-21.0.7-210614-linux510 at 2.5GB) on a Kexin brand 32GB card. The result: flash failed! I even shut off all of my Windows Security settings.

In fairness, I’ve tried the Raspberry Pi imager and while it doesn’t give me an error when flashing the card, it does hang when booting from the card.

I tried pasting the whole, but it exceeds the limits. Please let me know if there’s another way I can upload what is needed to help. Thanks.

Hello @davincim welcome to the forums and apologizes to hear that.

I understand that you are running Windows. Could you please mention us the version of Windows and the version of Etcher?

Finally could you please press ctrl+shift+i and share the console logs of the balenaEtcher once you get the result of flash failed?


Thanks, mpous. I’m running Windows 10 Home; Etcher 1.5.121.

I tried including the logs, but the restrictions of being a new user prevent me from doing so: too many “links” and too many characters.

Is there a portion of the log that I should include that will be allowed perhaps?


Sorry about that - can you use pastebin to paste the logs and share a link? Or is it limiting sharing links as well?

Great idea! Before I do, though, I paste the whole thing, right?

Nvm, I’m too eager to get this fixed. You can find the log here.

Hi. Yes sharing the full console output is best since we don’t know in advance what might be relevant. Thank you!

Thanks, pipex. Looking forward to feedback on the log I linked to above.

Oh, sorry @davincim I missed the link you shared. Looking at the logs, it looks like flashing and verification succeeds, but there is an issue unmounting the device. Searching the forums and on etcher issues, there have been some reports about conflicts with the same error and the main suspect seems to be the OS creating some system information files while the verification/unmounting process happens which lead it to fail.

Here is the relevant issue Lock the drive to prevent failure on verification · Issue #3197 · balena-io/etcher · GitHub

Could try the steps indicated on this post to see if they help fix the problem Flash failed on umbrel-os-v0.3.8 - #7 by tmigone?

In any case given the logs you shared, you should be OK to use the drive, since verification shows 100%.

After reading those posts, I decided to just skip the verification process. Perhaps I misunderstood, but locking the SD card didn’t seem right.

In any case, I’m still not able to boot from the card and have continued the discussion on their forum as it seems the issue is not Etcher’s fault.