Flash failed on umbrel-os-v0.3.8

Hello all,

I have recently bought a rasperry pi and am trying to flash to my brand new SD card. The file I am flashing is named in the title. I am trying to set up an Umbrel bitcoin/lightning node. I’m not the most technically savvy person so would appreciate some help. The process seems to go fine, it goes through 2 different flashing progress bars. The first seems to work fine, goes to 100% no problem, but when validating it gets to around 10% then just says ‘Flash failed!’

I have attached screenshots from the Balena console, perhaps someone can help me, which would be very appreciated.

Hi there, it looks like the process is failing in the validation stage at the end. Do you have a spare SD card to rule out it being the problem?

I asked the etcher team and they think this is probably related to this issue: Lock the drive to prevent failure on verification · Issue #3197 · balena-io/etcher · GitHub
In a nutshell, it means that the data Etcher reads from the device is not exactly the same as the one in the disk image that was written.

Most likely your image was flashed correctly but something wrote some files to the drive before the validation completed, changing its checksum. This can happen specially if you are running etcher on Windows. To avoid it, you should follow the instructions here How to prevent creation of "System Volume Information" folder in Windows 10 for USB flash drives? - Super User. That said, the validation step is not actually required, it’s just an added feature to verify the image was flashed correctly. You can try booting the SD card and see if that works.

The alternative scenario is that your SD card is broken and doesn’t write or read all the data it gets asked to. Since you say it’s a brand new card this is most likely not the problem, but worth checking if you have a spare one.

I don’t have a spare one no.

Hi, I tried to follow the instructions on the link you provided but failed at the first step. The first thing it tells you is to type ‘gpedit.msc’ in the Run dialog box and I am hit with the error message 'Windows cannot find ‘gpedit.msc’. Make sure you’ve typed the name correctly, then try again.


Are you by any chance running Win 10 Home, where user might not have the utility available? If so, you might want to check online for an alt option install this utility.

In the meantime, have you tried the drive directly (as my colleague suggested). It might very well be the case that the bootable drive works (validation steps is more of a verification piece not blocking one!).

Yes I am using Windows 10 home.

I did try the drive as recommended, but I am unable to connect to Umbrel.local on my browser, and the IP address for the device doesn’t work either. Since this isn’t Umbrel’s site I won’t trouble you guys with the additional problems I am having.

Hello cubemackie

I tried this on my Windows 10 system and although the verification failed for me too, the SD card still worked and booted. I connected an HDMI cable and keyboard and logged in to the device directly. I couldn’t reach the device via http://umbrel.local , but I didn’t have any external storage plugged in so the container exited with an error.

Try logging in directly via a console with username umbrel password moneyprintergobrrr