Failed to start Resin flasher service

I am trying out Resin on a Logic ML210G-12, using a wired ethernet connection (at the moment… I’m hoping to use the internal LTE modem eventually). The internal mSATA SSD came unformatted. I’m using the NUC v2.7.8+rev1 image, as that’s worked for me on a few random x64 computers before.

The boot messages carry on to various things, but always stops at “Failed to start Resin flasher service”. The device shows up in the Dashboard, but just says “Connecting…”. (I think that I saw it say it was downloading once.)

I tried booting up to Ubuntu 17.10 on a thumb drive, which works. Then I tried installing that on to the internal drive, and that worked. I reformatted the drive, making sure to use a GUID partition table, but still getting the same error.

Is there anyway to flip over to a console for me to see what the logs are and why the flasher service is failing?

Hey there!

Can you try pressing CTRL + ALT + F2, login as root, and then executing systemctl status resin-init-flasher?

I type in root (and enter) on the login: prompt and the cursor moves to the next line, but doesn’t come to a command prompt. A few seconds later the screen refreshes to the login prompt.

Related to this… when I reboot again on the USB image, I get the GNU GRUB command prompt. I haven’t figured out how to carry on to the normal Resin flasher boot without re-Etching this drive.

Hey there,

Are you running a dev image? If not, can you try with that, since it will give us much more information?

Yes, I was using a dev image. I decided to re-flash it and try to check it closer. Looks like I see something! The flasher is trying to use /dev/sda … which is actually the USB drive, not the internal drive. This explains why it starts acting weird after I leave it for a bit and why I have to reflash the USB drive between tries. How is it determining what is the internal drive?

I found sda referenced in this config file. I just cloned the repo and modified the file to have sdb instead. I’ve got a few things to install before I can build it, but gonna give that a whirl.

Ooof. Unfortunately running into a lot of issues trying to make my own image. :frowning:

Hi @eliot . This should make it that it won’t try to install on your USB stick from which you are booting.

If it’s the case that on your board the USB device is detected as sda and the internal media is detected as sdb, then you would also need to change and add “sdb” there too.

Can you double check please that in your case the USB stick is detected as “sda” and the internal media is “sdb”?

Thanks for the hints, @floion! I’m getting a Linux image up on my computer since I guess Mac can’t run Yocto build environment?

I confirmed by booting up with a GParted boot USB, and then booting up with the GParted boot and the Resin USB also connected. In both cases, the internal drive shifts to the last position (in the first case, it was sdb, in the second case, it was sdc).

I’ll let ya know how it goes here!

You could just etch your USB drive again, mount it on your computer, and then overwrite resin-init-flasher from partition 2 of the USB stick, under the usr/bin directory there with this version:

Then, on the same partition, you should be able to find the file resin-init-flasher.conf in the etc directory. Edit that file and add “sdb” to the INTERNAL_DEVICE_KERNEL definition.

Save these changes, unmount the USB stick and use it to flash your device.

Please let us know how this goes

In case you end up here because of this error message: I faced this when the PC wasn’t able to find any target harddisk.