Intel nuc never comes up

created a new app, downloaded the image and flashed it on an intel nuc.
it comes up first boot with a white screen and the resin logo in the center. nothing happens after that.
in resin it just shows it as Offline and Last Seen is “Connecting”. we’ve waited well over 10 mins and still nothing.
we tried new images, different usb drives, all the same.

Did an entry for the NUC show up in the dashboard when you did the initial install from USB? Also, is the NUC connected via Ethernet or WiFi?

yes it shows up in the dash, that’s where i see it say "Offline"
when i do the initial install it shows up instantly and shows it installing and postinstall, then goes offline and i power it back in then i get the logo screen and nothing again.

*connected via eth.

Hmm, that’s a strange one! Is there anything unusual on the network (proxy, etc.)?

Also, what version of resinOS is this?

no nothing strange. i even delete the app in resin and created one for raspberry pi’s to test it out and that worked fine.
it just seems to be with the nucs.
version is the recommended one Resin OS 2.2.0+rev1 (prod)

Do you see the flashing progress bar on the dashboard while the NUC is being flashed?

And to be sure, there is a hard disk installed in the NUC, right? (This has happened before!)

the flash happens fine. its after, i remove the usb, restart the nuc and it boots up with the screen that just has the logo. then never comes online in

going to try a previous resinOS version.

same thing with 2.0.6
when the log comes up after boot if i press any function key it brings me to the text bootup screen.
it stays at this.

and stays at Offline.

ok i did another install and watched the screen during the install and i noticed this near the end

@phynias please can you leave the provisioned NUC powered on, connected over Ethernet and send me the device UUID via PM so we can take a look.


unfortunately i don’t see how to send a PM on here.

@phynias you click @joe’s name (which will take you to this link) and click on the “Message” button

no message button for me.

the other question is, is joe still around to help on this right now.

message button suddenly started appearing.

Glad you were able to access it. He should be

@phynias if you pm me the link I can take a look, and if I can’t sort it out, i can get it to Joe. He’s in the UK, so is probably offline now, but will be coming online later.

I was unable to connect to the device over the VPN, which usually indicates network issues on the device side. Joe will know more, but I’d say the next step would be to try flashing a dev image and then either a) SSH into the device after it’s booted to look at logs, or b) connect to the device’s tty using a cable on the GPIO pins. We need to isolate whether something’s failing on the device, or it’s unable to get out to the internet after flashing.

Can you also post more specifics about the NUC model/version?


ok i install a dev version. how can i ssh in. i can ping it but ssh doesn’t work.