Etcher v1.4.4 release

The latest Etcher is out, get it from
This release fixes a few regressions we slipped into the UI:

v1.4.4 - 2018-04-24


  • Don’t display status dots with a quantity of zero on success screen
  • Correct wording of flash status to use “successful” instead of “succeeded”
  • Keep single drive-image pairs with warnings selected


  • Improve notification messages

this build is shit. not executable on windows 10 64 bit : Windows Defender Security is triggered right after clicking the Etcher 1.4.4 .exe file

nice! i downloaded myself the 1.2.1, version wich work.

While I don’t appreciate the tone, please see for details; this is default Windows SmartScreen behavior, which is applied to newly released software.


Couple of question

I am using manjaro (64 bit) as my OS.

Where is the checksum located?
I believe that the programme will run from a folder, so why install?

Linux version works fine for me :slight_smile: Just flashed the new Ubuntu. Happy days. Thanks for making this software and keep up the great work!

1 Like

I have noticed that

Is for the AppImage not the zipfile

Do you agree

Thank you to you and the team for reviewing my bug report so quickly, and pushing this fix out in just a few days - much appreciated! :grinning:

1 Like

Thanks a lot for your awesome and hard work - makes myself a lot easier :slight_smile: - very much appreciated!


@anon_private yeah, that looks correct – does it say otherwise somewhere? The SHASUMS256.txt has the following mapping, which is what you’re asking I believe:

8ff36aec4053bad0c80186d87571dc6eac8ad0263d54befb3a5d5c0fa71297c3  etcher-electron-1.4.4-x86_64.AppImage

@plittlefield @Richyread @nmaas87 thank you all for the kind words! We very much appreciate hearing that you’re happy with it :slight_smile:

That is correct for the AppImage file, but, if you look at the data that checksum is assigned to the zipfile

Ubuntu Mate 18.04
Etcher 64bits 1.44

The software propose to install in the menu but after nothing. The software does not show up
Could I still download the previous version ??

@jhermsmeier Great work!

I wanted to share some feedback which is a very minor quirk. When running Etcher v1.4.4 on OSX I’ve noticed that the ETA is rather optimistic when installing from a compressed format like .img.bz2. When imaging a 2.53 GB .img.bz2 to a 16 GB card on my laptop Etcher’s ETA was only 5 minutes or so from the start. By the time I got to 80% done the ETA was reporting 0m50s to 0m37s, yet it took another 5 minutes before the process was over.

The 2nd time I used the tool today I just used the full uncompress .img file. This time I received much more accurate ETA’s of about 20m0s. So, I suspect the ETA is just basing it’s information on the current files size and percent done, not the extracted size of the actual file.

Again, it’s not a huge deal, just a minor quirk.

1 Like

Hey @hlclark78, thanks!

The reason the ETA is so unreliable with bz2 compressed images is that the compression scheme doesn’t have an indicator for the uncompressed size (same with gzip), and hence the ETA becomes more of a guesstimate, and very well compressed zero-filled blocks in the bzip stream (which is a frequent thing near the end of disk images) can cause this to be significantly below the actual time needed.

We’ve thought about ways around this every now and then, but they all ended up being less performant than taking the hit of an potentially inaccurate ETA so far.

I had to register here to say that etcher does not work in mx linux 17.1. The program sees both the flash drive and the iso image, and asks for the root password. I enter the password, but the image does not go, it breaks down: anguished: Version 1.4.3 worked. I specify, it is a portable version of appimage.

пришлось зарегистрироваться здесь, чтобы сказать, что etcher не работает в mx linux 17.1. Программа видит и флешку и образ iso, и просит пароль root. Пароль ввожу, но запись образа не идет, срывается :anguished: Версия 1.4.3 работала. Уточняю, речь идет о портативной версии appimage

Tried to use 1.4.4 to create an SD card for my raspberrypi. It didn’t work. Etcher creates a boot image then asks to format the D: drive (F: is the boot image). If you format, the entire SD card is reformatted. If you don’t format, the image for the raspberrypi is unusable. The pi will not load properly. Used an older version a few months ago and it worked great. The new version is unusable.

@nekto thanks for the feedback – can you share what errors you are getting, if any?

@griffinj09 The dialog asking you to format the device is not from Etcher, but Windows – that happens if Windows doesn’t know the filesystems on that device, which can be ignored in this case.
Which image have you been flashing, and how the the Pi not load properly?

Hello jhermsmeier. thanks for the answer. the error of the program is that the image is not simply written to the memory card, the flash drive remains empty. literally a second after clicking on FLASH, its color immediately changes from yellow to blue, and it seems that there is an error in the access right, that is, etcher does not receive root privileges, although I give it. I installed version 1.4.4 from your repository and it works fine, but version 1.4.4 of the appimage unfortunately does not work. it’s sad because I prefer portable programs. Perhaps the error is that you were building an appimage package in ubuntu on April 18.04, and there is no gksu anymore, and I’m using debian 9, where gksu is used.

здравствуйте jhermsmeier. спасибо за ответ. ошибка программы заключается в том, что запись образа на карту памяти просто не идет, флешка остается пустой. буквально через секунду после нажатия на FLASH, его цвет тут же сменяется с желтого на голубой, и такое ощущение, что имеет место ошибка в праве доступа, то есть etcher не получает привилегии root, хотя я его даю. Я поставил версию 1.4.4 из вашего репозитория и она работает нормально, но версия 1.4.4 appimage к сожалению не работает. это огорчает, поскольку я предпочитаю портативные программы. Возможно ошибка в том, что вы собирали пакет appimage в ubuntu 18.04, а там уже нет gksu, а я пользуюсь debian 9, где используется gksu.

Really loving Etcher. Thank you and keep up the great work. If I could be so bold as to request one thing to make it even more awesome, is a backup feature… ie to take what is on a USB and make an ISO from that… as in going in the opposite direction that Etcher does currently. :slight_smile: