Etcher starts with white screen on Windows10

When starting both the portable and standard balenaEtcher on win10 they both stop at a white screen. ctrl+alt+i does not bring up anything.

I have tried to reinstall and uninstall a few different versions but no luck.

Welcome to the forums! Which version of balenaEtcher are you using? I was not able to reproduce what you described in the latest version (1.5.69) on Windows 10.

balenaEtcher-Portable-1.5.69 and standard. I did fresh installs today trying to fix the issue.

Is there anything I could check? Its working fine on my laptop, this is specifically happening on this computer.

Hey, would it be possible to post the logs from the developer console? To open the developer console, use ctrl+shift+i on windows I believe.


after I reload I get this in the console

| | | | |
| |
| |
| | ___ _ __
| || / | ’ \ / _ \ '|
| |
| || (
| | | | / |
/ ____|| ||___||

Interested in joining the Etcher team?
Drop us a line at

Version = 1.5.69, Type = local
C:\Users\prcds\AppDa…\resin-corvus.js:39 Thu Dec 12 2019 14:26:32 GMT-0600 (Central Standard Time) Application start ({“packageType”:“local”,“version”:“1.5.69”,“applicationSessionUuid”:“2bcd10e9-0ef1-40c5-8ac9-ef1e0754a635”,“sample”:0.1})

@prcdslnc13 there are a couple of Github issues that may help with this one.

The first is this one (note the reply that says solved, and take a look at the link there):

The next is this one which contains not only a list to a lot of other related issues too, but also a suggestion that the issue may lie with a virus checker:

Take a look at these ideas and if you’re still experiencing an issue, consider replying to the issue on Github that seems most relevant to the problem you’re having.

I hope this helps!