Etcher killed my USB stick

I recovered the stick by entering the “Gestion des disque” that I suppose is called “Disk Administration” in the English version of Win 10. Th USB stick was not listed in the top part of the screen but appeared as a square in the lower part. I did right click on that square and selected Format and that is how I recovered my stick. The Format process will recreate the system volume information for the stick.
Best regards
superpapi

2 Likes

EN LINUX:

  1. Expulsar unidad USB (con clic derecho en la misma, en el explorador de archivos, y luego en expulsar).
  2. Instalar Gparted o Partition Manager de KDE y/o abrir la aplicación
  3. Borrar tabla de particiones del pendrive (clic derecho, en el panel o espacio derecho) y luego crear una nueva (de tipo MS DOS o MBR).
  4. Clic derecho, Nueva. Elegir:
    • sistema de archivos FAT32 (si se usará en Windows, y sino, ext4)
    • tipo: Primaria
    • etiqueta: el nombre que quieran
    • lo demás queda sin tocar
  5. Aplicar cambios

En Windows es similar.


IN LINUX:

  1. Eject USB drive (with right click on it, in the file browser, and then eject).
  2. Install Gparted or Partition Manager of KDE and / or open the application.
  3. Delete partition table from the pendrive (right click, in the panel or right space) and then create a new one (type MS DOS or MBR).
  4. Right click, New. To choose:
    • FAT32 file system (if used in Windows, and otherwise, ext4).
    • type: Primary.
    • label: the name you want.
    • The rest remains untouched.
  5. Apply changes.

In Windows it is similar.

Ubuntu 18.04.2

Tried every one of those ‘tricks’ and windoze cannot reformat the stick.

Shows up as 2.2 meg.

It WAS a two terabyte stick.

I wanted a bootable system to copy everything of value and have it with me.
The entire drive was used in 3 partitions.

I do have a Linux Mint 17 computer, but the person that installed it put in a password and promptly forgot to either write it down, remember it himself, or tell me.
So I can’t even try to recover it there.

Hey @CrustyOldGeezer, welcome to balena forums!
Could you share the brand/type of your drive, and some detailed steps you followed here please? Thanks!

@CrustyOldGeezer, if you are an advanced user comfortable with Linux and simply lacking access to a Linux computer, you could try running Linux in a VirtualBox virtual machine (install the extension pack too, and configure the VM settings to enable USB 2.0). After Linux is up and running with the extension pack and USB enabled, use the VM window “Devices” menu to assign the USB stick to the VM instead of the host OS. At that point, you should be able to use the Linux solution described here:

Admittedly, using a VM as described above is not a straightforward process and not recommended for the average user, but it’s an additional option.

Yeah, the only thing “advanced” about me is my age (72).

Dan, a ‘friend’ put mint 17 on around 2012 or so. It was the latest at the time. Put in a password and promptly forgot what it was.

Been fighting it trying to do anything that required admin privileges since.

My original intention was to build a bootable Linux USB that I could plug in and boot into a working system and remove 17 and put on a new version without the admin thingy.

@CrustyOldGeezer, it may be possible to reset the root password of a Linux computer by booting in “single user mode”. Some pointers:

Here’s a link to a very similar question in Rufus’s FAQ: https://github.com/pbatard/rufus/wiki/FAQ#help-rufus-damaged-my-flash-drive
It stands for Etcher as well.

I have problems with Etcher as well. It has broken several Lexar 8G drives. Here is what happens:

I’m on windows10. I download an ubuntu iso, and use Etcher to burn it to my usb.
The usb works fine on Linux, I am able to re-use it there using the Linux version of Etcher.
I try to burn another iso on windows, and it is unable to. I try to reformat it - using right click in explorer, using partition manager, using diskpart - they all fail. I put it back in linux, and reformat it to NTFS, and it works fine - I can now read and write to it. Until I go to use Etcher on the same usb again. Etcher gets to 22% complete and freezes. The client window is blank white, all I have is the title bar which says ‘Etcher - 22% Flahing’.

I’ve gone back to using UNetbootin. Not so asy to use, but it has yet to break anything.

@darkoverlordofdata welcome to the forums!

It would be beneficial for us if you could check the output of the console when this happens. As you’re on Windows you can press CTRL-SHIFT-I and then check the output of the console tab when you’re flashing the drive and it gets stuck. If you can share that here we can hopefully figure out what’s going on.

First time works great. I can burn an iso and install it on another computer. When I go to re-burn the same usb in Etcher:

the gui displays:

Starting…

The process ended unexpectedly. Please try again, and contact the Etcher team if the problem persists.

I’ve attached the log.

If I right click on the drive and select Format…:

Windows was unable to complete the format.

If I run diskpart, it also fails -

Microsoft DiskPart version 10.0.17763.1

Copyright © Microsoft Corporation.

On computer: DESKTOP-DOJU898

list disk

Disk ### Status Size Free Dyn Gpt


Disk 0 Online 476 GB 1024 KB *

Disk 1 No Media 0 B 0 B

select disk 1

Disk 1 is now the selected disk.

clean

Virtual Disk Service error:

There is no media in the device.

At this point, with UNetbootin, either reburn or reformat works.

I finally figured out how to repair the usb so I am able to re-use it. I fire up the Ubuntu live usb in one port, put the usb in the 2nd port, and run gparted. I select the usb, and fo the following:

Device -> Create Partition Table

select msdos

Partition -> New

filesystem fat32

Edit -> Apply All Operations

Then I reboot back to windows and I can re-use the usb for whatever I want.

Etcher is only a program, it can’t kill your usb drive.
I’ll repost this link again https://github.com/pbatard/rufus/wiki/FAQ#help-rufus-damaged-my-flash-drive .
If Etcher fails at 22% consistently, your usb drive most probably has issues there.
Creating a new partition table works because it only requires to write to the first few kilobytes of the disk.

Not sure how old this is, but I found a working fix for this that works in windows 10

Search for MiniTool Partition Wizard Free and it will fix it. I didn’t have Linux available to fix this and diskpart for windows did not work for me.

1 Like

Hello, my 120GB ssd become not supported to S.M.A.R.T.
I use my ssd as usb external drive to install Lubuntu, I burn Linux Lubuntu ISO with Etcher Version 1.5.56 Mac OS Mojave. Is there a way to fix it?

Hi, could you please provide more details on the issue? Etcher’s goal is exactly that of flashing images, did you already try to use the target you just flashed?
Also, I’m not sure about what S.M.A.R.T. is and how it could be affected by the application :confused: thanks for the patience!

Appearing to kill a flash card when flashing a boot system is a common problem in my experience. Especially when using Windows. I’ve always been able to recover the drive to full capacity using the free version of EaseUS Partition Master. I pretty much expect to have to do it after using a flash card/drive for a boot medium. Just my experience and maybe will help others.

It is better to say that the flash card is not “killed”, as Etcher can’t do such a thing (luckily) - it just has a partition table that the OS doesn’t recognise because you just flashed another OS in it, which makes sense and is especially true on Windows/OSX, while Linux usually has less issues.
We provide some steps you can follow on the different OSes if you want to recover “broken” drives in our docs, but as you mentioned there are also many other tools that might do the trick depending on the OS and the flashed target.

I have not been able to us Etcher on Windows 10 to create an image on any of my SD cards. It would leave the SD card un-usable.

I would have to use DISKPART to clean and then re-partition the card and and format it again. Lot of people are saying their USB/SD are bricked, but most likely they can be fixed by using DISKPART. Run DISKPART, then LIST DISK your disks will be number, do a SELECT DISK and the number of your drive, then I would do a LIST DISK again and to make you see a * next to the disk you want to fix and then enter CLEAN, this will delete all data and partitions off the disk! Next do CREATE PART PRI this will recreate a new primary partition. Now you can format it, there are many options for formatting the disk but FORMAT FS=FAT32 will do a full Fat 32 format and can take hours, you can add QUICK to do a quick format.

How I resolved Etcher from locking up my Window 10 system every time I used it was to switch to Rufus 3.8. I have tried running Etcher is Admin mode, used a lot of difference USBs and SD cards but would lockup every time. The only program I have had to lockup my Window 10.

As mentioned earlier and in numerous occasions, Etcher doesn’t apply any logic to the writing process, as opposed to Rufus, it just writes byte-to-byte whatever is the content of the image, which might result in a partition table unreadable by the OS. For some images, Etcher might not be the best choice if the image requires any manipulation (Windows images, some Linux distros, etc)