Etcher killed my USB stick

I have a similar problem and manage to find a solution. What happened is that after burning the iso I coundn’t use the usb device, it didn’t appear in the windows explorer, only in the ‘‘diskpart’’.
In the diskpart you need to type:
-“list disk”
-“select Disc X” - select the disk you would like to fix
-“create partition primary” - if already doesn’t exist

after that, you need to assign a new drive letter to the Device
https://www.easeus.com/resource/fix-please-insert-a-disk-into-removable-disk.html
in this link above you can see how to do it step by step, it’s pretty simple.

I hope this can solve your problem.

I did an install of a linux product yesterday on one of my old laptops. the linux page linked etcher. I tried to flash two different usb drives and balena etcher made both of them unviewable or useable. I started researching ways to fix it. But before I did that, I tried to flash the drives with Rufus. Rufus was able to see the drives and flash them with no additional steps to recover them before flashing! I am not affiliated with Rufus or any other tech company of any kind…

The issue I had with Etcher on an USB stick a year ago or so was solved. It was most likely no problem with Etcher for me, nor the USB; it was my lack of knowledge about those different file systems which are created when burning the ISO file for eg Linux installation, and that Windows and macOS cannot really recognize Linux file systems.

My latest use of Etcher was 1-2 weeks ago, on macOS, to create a Linux ISO file on a USB stick, and it went fine without any issue.

After creating a bootable Linux flash drive using Etcher, the flash drive may look like completely dead in Widows environment (although there is nothing wrong neither with Etcher nor with Flash Drive). It is clear incompatibility between Windows and Linux filesystems. In my case I was not able to write another image using Windows tools again. Windows disk administrative tools and diskpart utility were useless to recover the Flash Drive back into “windows mode”.
My solution is following.
If you have no access to a computer running Linux, you can make another bootable flash drive to run Gparted (Gnome Partition Editor). https://gparted.org/liveusb.php
Then:

  • boot your computer using that liveusb drive (Gparted will start automatically);
  • insert your “dead” usb flash drive;
  • choose “Update device list” command from the main menu;
  • select your target device from drop-down menu in the right-top corner. Its name will be most likely \dev\sdc - check its size to be sure is your “dead” usb drive;
  • use mouse to navigate to instruction to change the device file system to FAT32;
  • Click the “tick button” to apply your instruction;
  • Done.
    Remove your flash drive and it is ready for Windows again.

Thanks to @taprackpull 01-Feb-19 and @derek 30-Apr-20, I have recovered both USB Flash Memory sticks that got “bricked” whilst using balenaEtcher-Portable-1.5.98.exe running on Windows 7 as Admin to Flash linuxmint-19.3-cinnamon-64bit.iso onto USB 16Gb.

Etcher failed immediately with an “Oops something went wrong …” notification helpfully suggesting that either the drive was read only or the ISO image was corrupt - neither true!

I wasn’t able to screen shot this but other screen shots are attached, including the method of recovering the USB.
Etcher killed my USB stick.pdf (513.3 KB)

I observe that it is the Create Partition Primary command in DiskPart.exe, rather than the Recover or Clean, that restores the Volume back to RAW and Healthy. Then a Windows Disk Format succeeds in setting the format to FAT32.

I understand that tool changes the disk format to suit Linux and this is incompatible with Windows. However it is clear to me that in the process the tool trashes the drive (as far as the Windows environment is concerned) before it completes the transfer of the ISO image.

Obviously the tool has to be able to write the image successfully in the Windows environment before changing the disk format to suit Linux. It also needs to be able to restore the disk format back to suit Windows for further updates. So that the user does not need to resort to using something like DiskPart.exe to do this.

However this leaves me no further forward towards getting Mint 19.3 Cinnamon 64-bit flashed onto USB.

Please can someone suggest a good dependable alternative to Etcher, cos I’ve wasted enough time on this and clearly there is a long standing problem here that ain’t getting fixed.

Hi @HunkyDunc – sorry to hear you ran into problems using Etcher. Can you let us know if you successfully verified the Linux Mint ISO image you downloaded using the instructions here? If the image fails this step, it would definitely be worth downloading it again.

All the best,
Hugh

Hi Hugh,
Yes I had verified the Linux Mint ISO. Thanks.

Rufus worked a treat first time; created a bootable USB, FAT32 with a LINUXSYS MBR and loaded with the Linux Mint ISO.

Happy it worked for you.
Rufus is a software that specialises in creating bootable USB sticks for windows. In contrast Etcher really only flashes an image but makes no attempt to make it bootable. So if your image has issues booting on your target system rufus might be the better tool.

I was just flashing an image from my new USB stick (where I had a backup image stored for my raspberry pi) on to my SD card and it killed it. Is this something you are not supposed to do?

I receive an abrupt message on Balena Etcher and now the usb stick doesnt appear in windows or Linux. It just appears on Window Disk Manager as “No Media”. Can’t reformat it.

It doesn’t appear on linux when I run the command df -h

It seems unrecoverable.

Hi,
flashing from a USB stick seems allright to me.
On windows the device will only show up if it contains a recognized file system and on linux it only shows up in df if it was mounted.
In linux you could use gparted or fdisk to examine the drive. lsblk will show you the block devices in your system, you can run it with and without the SD-card to check which device it is. On my computer an SD card will show up as /dev/mmcblk0.

Hi

Thanks for your prompt reply.

I just installed gparted on raspbian and examined it, but the USB device doesn’t appear on gparted (I don’t see any /dev/sda). It only detects the pi sd card. Same with lsblk. It doesn’t show any sda devices.

When I remove the USB stick however I get a notification “Drive was removed without ejecting, please use menu to eject before removal”.

Also, it seems I may have had an error with the original img file which I tried to flash using BalenaEtcher, hence it stopped abruptly.

Please let me know if there is anything else I can try based on the above to recover the USB.

Sorry, I might have misunderstood.
You tried to flash an SD-card with an image you had on a USB stick but instead of flashing the SD the USB stick was modified and does not show up any more ?
Are you sure you selected the right target device? This sounds like you might have flashed your USB stick…

Hi, it wouldn’t have been possible for me to flash the USB stick as the raspbian image file was sitting on there. I was flashing the SD card with the raspbian image so I can use it with my pi.

USB stick (with image file) --BalenaEtcher-----> SD Card

However, the flashing was interrupted abruptly (which may have been due to an error on the image file, but it killed the USB stick.

I hope that makes sense.

Hi, you can follow https://www.pendrivelinux.com/restoring-your-usb-key-partition/ to re-create the partition table. For example, using the cli in windows they mention in that link that you would do:

Manual Method via Diskpart – Windows:

Open a command Prompt as administrator (cmd.exe)
Type Diskpart and press Enter
Type List Disk and press Enter
Type Select Disk X (where X is the disk number of your USB drive) and press Enter
Type Clean and press Enter
Type Create Partition Primary and press Enter
Type Active and press Enter
Type Format fs=Fat32 Quick and press Enter
Type Exit and press Enter

Thanks to System 76 for barely compiling an installation guide, not to mention any useful FAQs or troubleshooting. I have a couple friends who play with Linux distros in dev and this is the 4th time I’ve been asked to repair a USB. And guess what? All 4 times were instances where the person used Etcher, as instructed, to flash System 76’s POS/POP OS and after successful installation of the OS, as I’m told, the drive is unusable, unable to be cleaned in diskpart, unable to be formated, etc. I’ve always been able to work around diskpart in WIN10 to success but this SANDISK 32GB is not having it. I keep getting the message along the liens of “Cluster Size too small” …here’s a couple lines from my Event Viewer:

Cannot zero sectors on disk \?\PhysicalDrive2. Error code: 5@0101000F

I’ve tried my PC, running WIN10 with 16GB RAM and a couple SSDs and my 2 laptops. All 3 provided the above error in event viewer. Can anyone help me out? If not I’ll just trash the hell out of this software all over my XDA/reddit and personal forums so that hopefully people will stop asking me to fix something that, had I been the developer, I would have fixed A LONG TIME AGO.

Here is a solution you can try (double cleaning with diskpart): https://github.com/balena-io/etcher/issues/1991#issuecomment-361077474

Hi all!

I found a quick workaround on Mac OS X (Catalina):

  1. Open Disk Utility;
  2. Create an empty image file .dmg (File > New Image);
  3. Set the new image size as the original USB size (check the available capacity on disk);
  4. Select the filesystem you need ( I used ExtFAT for my needs)
  5. Open Etcher;
  6. Select the freshly created empty image as the source, and the “dead” USB as the target;
  7. Burn it;
  8. Delete the empty image on your computer.

Now the key is recognized again under Mac/Windows/Linux.

Cheers,
Simon

I recently used a USB stick as a boot to install the latest Pop!_OS 20.04 LTS and everything went well. But it seems like after I was done flashing the popos iso onto my USB stick, it seems like the windows 10 cannot find the USB anymore even though its plugged in, i know that etcher delete the exisiting partition and make new ones to download the iso(correct me if i am wrong). The disk management seemed to know that the disk is there but when i try to change the driver letter or format the systems just tell me it cannot find the file specific. I have tried using the MiniTool Partition Wizard to wipe everything on the USB, format it and create new partition, it does show up after the above steps. But once i eject the usb, it reverts back to being unable to be use or open again.
This issue is only on window 10, it seems like i can access the usb when i am on Pop!_OS, so I am not sure why.
Please help.
Thank you

Your USB stick is not damaged…It’s just that the Linux Mint ISO is creating partitions for making it bootable (for UEFI). It does the same on other OS installed on Legacy.