Blank screen on Windows 7 with every version of Etcher

Hi i have first downloaded Etcher a few years ago and it was starting with a blank screen. Today i tried it again and it’s still same. As far as i can see there are a lot of people that experienced this for various reasons behind the scene. So what im trying to tell that it’s really annoying to be not able to use this convenient software that is not fixed the core reason behind the issue. Maybe it’s time to fix it for real? Maybe a complete re write of the software i don’t know

Hi there,

You say you downloaded Etcher some time ago - have you updated it to the latest version?

There was a previous bug which was fixed in version 1.5.91 - the current version for Windows is 1.5.106 and can be found here: https://github.com/balena-io/etcher/releases/download/v1.5.106/balenaEtcher-Setup-1.5.106.exe

Phil

Hi thaks for reply. I completely deleted the etcher with official uninstaller and did a clean up with ccleaner when i installed it first time. So no i didn’t update it over the old version but downloaded the latest version of etcher a few days ago and installed it. Blank screen problem was still there. I tried the version you gave me but it’s still same. When i press ctrl + shift + ı there is only one error and nothing else in the code section. The error message is: Not allowed to load local resource: file:///C:/Users/user123\AppData\Local\Programs\balena-etcher\resources\app\generated\index.html chromewebdata/:1

By the way i tried to open it with administration rights and with compatibility mode but same thing happened…

Hello,
Did you edit the logs ?
file:///C:/Users/user123\AppData\Local\Programs\balena-etcher\resources\app\generated\index.html
The slash (not antislash) before user123 looks out of place.
Is this file available on your computer ?
Is there anything running that could prevent etcher from accessing it ?

I remember having issues on Windows 7 when the Visual C++ redistributable was not installed, you can get it from here https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads .

I just edited the username. I’m attaching the original error message as image. I tried to install or i shall say updated the Visual C++ but no luck. index.html file is exist but it’s just an empty html file. I deactivated kaspersky security cloud but again nothing changed and that is the only thing that might prevent it from accessing it.

Interesting.
Maybe it is due to the hashtag in your username ?
What do you see in the Network tab of the developer tools ?

1 Like

@Mekanik97
I think it’s due to the hashtag sign.
Can you try this from the console:

require('electron').remote.getCurrentWindow().loadURL(`file://${path.join('/', ...__dirname.split(path.sep).map(encodeURIComponent), 'index.html')}`);

If it fixes the issue, it will be in the next release.

Hahah i guess you are right it was probably happening because of hashtag sign. I created a new user without any symbols, tried to run and it did work. Also i extracted the setup of Etcher with winrar and tried to run the program with hashtagged user name but same thing happened. When i move the extracted folder to another HDD (from C: to D:) it did work. Exact same thing happened with portable version too. Also the code you gave me didn’t work. Im attaching the error codes and network tab. Thanks for help

Thanks for reporting this problem.
Do not hesitate to reach out to us if you have any further problems

Hello @Mekanik97
This should be fixed in v1.5.108
Thanks for reporting it.