Etcher 1.5 problems on Mac


#1

I installed Etcher v1.5 on my iMac (v10.14.3), but when I launch the app, nothing appears. I can quit the program and pull up the developer tools window, but the typical Etcher window doesn’t appear. Any suggestions?

FYI, I had an older copy of Etcher that I had used multiple times that I uninstalled prior to installing v1.5.


#2

Hello @bwanajag
I’ve tested it on 10.14.2, it worked.
Do you see a blank window or no window at all?
What do you see in the developer tools console?


#3

There’s no window at all. I see the balenaEtcher name at the top left of the screen (to the right of the apple), and have access to some of the menu items.

As a note, the install I’m referencing above was on an iMac. I also installed it on my MacBook Pro and it worked correctly. However, I’ve uninstalled and installed it several times on my iMac and it does the same thing every time - no window, only the application
name in the top left


#6

I have the exact same problem on my iMac. I’ve used Etcher 1.5.5 last week and it was fine, now no window.


#7

I’m in the exact same boat. installing an older 1.4.4 version on macOS 10.14.3 in a 2015 5K iMac.

Here’s a link to a .gif showing the issue: http://links.shdc.io/25e2acd767ca


#8

Same problem on MacOS. I am going to go back to using Etcher app for now. This has been posted for 3 or 4 weeks. Is anyone looking into this?